Topic Sponsor
2009 - 2014 Ford F150 General discussion on 2009 - 2014 Ford F150 truck.

Lead Frame Problem

 
Old 02-09-2019, 11:19 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Aug 2016
Posts: 548
Received 58 Likes on 45 Posts
Default Lead Frame Problem

Iíve had 20+ F150s and I finally got the lead frame problem 20 hours away from home in ice and snow. Luckily my truck did not shift into 1st. I got the usual symptoms: no speedometer, wrench light on, airbag light, no 1, 2, or 6th gears and I could not manually shift. I did make a video of when it happened.

Anyone in Canada have this fixed by their dealer under Fordís recall?
5.0nly is offline  
Old 02-10-2019, 12:07 AM
  #2  
How's she goin' eh?
 
M0RRIS's Avatar
 
Join Date: Jul 2015
Location: South Detroit
Posts: 3,294
Received 312 Likes on 278 Posts
Default

Sorry no, I’m just outside the window on month I believe. Sub’d though. Good luck
M0RRIS is offline  
Old 02-10-2019, 02:49 AM
  #3  
Senior Member
Thread Starter
 
Join Date: Aug 2016
Posts: 548
Received 58 Likes on 45 Posts
Default

Do you know which production dates were effected? Iím on mobile so canít easily search.

Also, does anyone know what the hell this is (the green)?

5.0nly is offline  
Old 02-10-2019, 05:29 AM
  #4  
Senior Member
 
PerryB's Avatar
 
Join Date: May 2014
Location: Chico, Ca.
Posts: 3,641
Received 575 Likes on 471 Posts
Default

I'm thinking it's refrigerant oil, it looks like you have a leak in your a/c condenser. Maybe from a stone strike.
PerryB is offline  
Old 02-10-2019, 07:17 AM
  #5  
How's she goin' eh?
 
M0RRIS's Avatar
 
Join Date: Jul 2015
Location: South Detroit
Posts: 3,294
Received 312 Likes on 278 Posts
Default

https://ford.oemdtc.com/2679/16n02-m...2-ford-lincoln

Dearborn
February 11, 2011 through September 8, 2012
Kansas City
April 5, 2011 through June 13, 2012


I’m actually right in the middle. July 2012 build date. I’ve been lucky, didn't this affect eco’s only?
M0RRIS is offline  
Old 02-10-2019, 08:11 AM
  #6  
Fleet Technician
 
Rnlcomp's Avatar
 
Join Date: Feb 2013
Location: Big Easy
Posts: 22,962
Received 4,642 Likes on 3,625 Posts
Default

Originally Posted by 5.0nly View Post
Do you know which production dates were effected? Iím on mobile so canít easily search.

Also, does anyone know what the hell this is (the green)?

That is the leak detecting dye they use in A/C systems. Put a UV light on it and watch it glow. I'd say your condenser is leaking.
.
Rnlcomp is offline  
Old 02-10-2019, 08:35 AM
  #7  
Senior Member
 
46L281GT's Avatar
 
Join Date: Jun 2014
Posts: 222
Received 26 Likes on 20 Posts
Default

I have replaced the lead frame in my sister's '11 eco at 145k and in my friend's '12 5.0 with around 125k. They're actually pretty easy to replace if you have the time. This spring I'm going to replace it when I do a trans fluid change since I'll already be in there and I don't want to risk it happening to my '13 eco at 121k currently. Best I remember, the part is only like 120 bucks.
46L281GT is offline  
Old 02-10-2019, 04:03 PM
  #8  
Senior Member
Thread Starter
 
Join Date: Aug 2016
Posts: 548
Received 58 Likes on 45 Posts
Default

Originally Posted by M0RRIS View Post
https://ford.oemdtc.com/2679/16n02-m...2-ford-lincoln

Dearborn
February 11, 2011 through September 8, 2012
Kansas City
April 5, 2011 through June 13, 2012


Iím actually right in the middle. July 2012 build date. Iíve been lucky, didn't this affect ecoís only?
Mine was July 2012 as well. Letís see what the dealer says.
5.0nly is offline  
Old 02-10-2019, 05:37 PM
  #9  
How's she goin' eh?
 
M0RRIS's Avatar
 
Join Date: Jul 2015
Location: South Detroit
Posts: 3,294
Received 312 Likes on 278 Posts
Default

Originally Posted by 5.0nly View Post


Mine was July 2012 as well. Let’s see what the dealer says.

OMG! Our trucks coulda been besties at the plant! Lol

seriously tho, what are the last 5 digits of your VIN? Mine is 42800.
M0RRIS is offline  
Old 02-10-2019, 07:41 PM
  #10  
Senior Member
Thread Starter
 
Join Date: Aug 2016
Posts: 548
Received 58 Likes on 45 Posts
Default

Originally Posted by M0RRIS View Post



OMG! Our trucks coulda been besties at the plant! Lol

seriously tho, what are the last 5 digits of your VIN? Mine is 42800.
44787 lol

Did your dealer fix this for you? Could you provide the service record to my dealer? I bet theyíll tell me I need a new transmission.
5.0nly is offline  

Thread Tools
Search this Thread
Quick Reply: Lead Frame Problem


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: