5.4 Problem links. - Ford F150 Forum - Community of Ford Truck Fans

Topic Sponsor
2004 - 2008 Ford F150 General discussion on the 2004 - 2008 Ford F150 truck.
Sponsored by:
Sponsored by:

5.4 Problem links.

Old 06-05-2013, 11:10 AM
  #1  
Meaner than Ymeski
Thread Starter
 
bobkyle2's Avatar
 
Join Date: Oct 2009
Posts: 23,095
Thanked 793 Times in 456 Posts
Default 5.4 Problem links.

5.4L 3V Spark Plugs Engine Build Dates before 10/09/07

https://www.f150forum.com/f4/5-4l-3v...09-07-a-56871/

------------------------------------------------------------------

The Final Repair Guide to 5.4 Cam Phaser Tick/Knock Sound

https://www.f150forum.com/f4/final-r...-sound-141266/

------------------------------------------------------------------

Bog down moan sound issue solved!

https://www.f150forum.com/f4/bog-dow...solved-166431/

------------------------------------------------------------------
Most common links for 04-08

https://www.f150forum.com/f4/stop-be...l-links-42829/

Last edited by bobkyle2; 06-06-2013 at 01:51 AM.
bobkyle2 is offline  
The Following 5 Users Say Thank You to bobkyle2 For This Useful Post:
Arizona Tumbleweed (10-29-2017), artsamm (04-13-2018), fone_fitty (10-21-2014), quincyjosh (09-19-2018), WreckZ (06-06-2014)
Old 06-05-2013, 12:24 PM
  #2  
2015 F-150 King Ranch 4x4
 
dos0711's Avatar
 
Join Date: Jun 2011
Location: Northeast, Florida
Posts: 824
Thanked 91 Times in 67 Posts
Default

How about one for exhaust manifolds?
dos0711 is offline  
The Following User Says Thank You to dos0711 For This Useful Post:
normiss (09-27-2014)
Old 06-06-2013, 01:50 AM
  #3  
Meaner than Ymeski
Thread Starter
 
bobkyle2's Avatar
 
Join Date: Oct 2009
Posts: 23,095
Thanked 793 Times in 456 Posts
Default

Adding more links now.
bobkyle2 is offline  
The Following User Says Thank You to bobkyle2 For This Useful Post:
fone_fitty (10-21-2014)
Old 08-09-2013, 12:54 PM
  #4  
Junior Member
 
Join Date: Aug 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Angry Power problems while A/C running

Okay i need some help here. 2005 f150 fx4 only 70,000 miles. When putting pedal to the floor there is no pick up to the truck at all when it is hot out and the a/c is running. I am not talking just a little slow, i'm talking to dangerous to attempt merging on the highway. Now let me give you some history on the truck. Was bought used only 30 some thousand miles. We had spark plugs replaced at 50 some thousand. We also had a tapping noise coming from the engine. Had the cam phaser fixed last summer, tapping never went away. Now we are having this power problem. Only happens when the weather is hot and the a/c is running. Took it to a mechanic and couldn't find anything wrong with so he sent it to ford who hooked it up to the computer and ran like 25 test and everything came back fine. So far no one can find what wrong with it and even ford says everything shows up normal. Anyone else having issues or knows what this maybe? Please help.
2005-FX4junk is offline  
Old 08-13-2013, 08:59 PM
  #5  
Junior Member
 
Join Date: Jul 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by 2005-FX4junk View Post
Okay i need some help here. 2005 f150 fx4 only 70,000 miles. When putting pedal to the floor there is no pick up to the truck at all when it is hot out and the a/c is running. I am not talking just a little slow, i'm talking to dangerous to attempt merging on the highway. Now let me give you some history on the truck. Was bought used only 30 some thousand miles. We had spark plugs replaced at 50 some thousand. We also had a tapping noise coming from the engine. Had the cam phaser fixed last summer, tapping never went away. Now we are having this power problem. Only happens when the weather is hot and the a/c is running. Took it to a mechanic and couldn't find anything wrong with so he sent it to ford who hooked it up to the computer and ran like 25 test and everything came back fine. So far no one can find what wrong with it and even ford says everything shows up normal. Anyone else having issues or knows what this maybe? Please help.
If you ever find out the problem let me know. I have a 04 Lariat with a 5.4 in it and I'm having the same problem except it doesn't matter if the ac is running or not. I'm taking it the ford dealership this weekend for its first set of tests
mrhart is offline  
Old 08-15-2013, 11:38 AM
  #6  
Junior Member
 
Join Date: Aug 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by mrhart View Post
If you ever find out the problem let me know. I have a 04 Lariat with a 5.4 in it and I'm having the same problem except it doesn't matter if the ac is running or not. I'm taking it the ford dealership this weekend for its first set of tests
you they let you know what is wrong with yours please fill me in to. I had mine at the dealership all they said was we feel the lack of power but nothing it coming on the test. We are stumped ourselves. amazing that ford builds something they cant fix or dont know what it is to fix.
2005-FX4junk is offline  
Old 08-25-2013, 08:17 PM
  #7  
Junior Member
 
Join Date: Oct 2012
Location: Berea, Ohio
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

5.4 Problems!!!!!!!!!!!!!!!!!
So I have a 2004 F-150 that just passed 80,000 miles and a month ago it started making a very loud noise on startup, but only cold startup, meaning if I haven't used the truck in about three hours. Now I went on youtube to research and found a video of a truck making the exact same noise! Here is the link:
Can anyone verify what this is??? Some poeple are saying cam phasers and some are saying I'll need a brand new engine! Thanks everyone
acate76 is offline  
Old 08-26-2013, 10:33 PM
  #8  
Junior Member
 
Join Date: Oct 2012
Location: Berea, Ohio
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by mrhart View Post
If you ever find out the problem let me know. I have a 04 Lariat with a 5.4 in it and I'm having the same problem except it doesn't matter if the ac is running or not. I'm taking it the ford dealership this weekend for its first set of tests
I am at a loss here too I've asked countless people nobody knows but I do know it shouldn't be making that noise. Please let me know if Ford actually figures out whats wrong with it.
acate76 is offline  
Old 08-27-2013, 11:31 AM
  #9  
Junior Member
 
Join Date: Jul 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by acate76 View Post
I am at a loss here too I've asked countless people nobody knows but I do know it shouldn't be making that noise. Please let me know if Ford actually figures out whats wrong with it.
Spent over $1000. Got all new spark plugs, a new #7 boot(mine was bad), and 2 other BS parts replaced. I get about 1 mpg better now but still have the same issue. Im going to see about replacing my stock intake and try cleaning or replacing the fuel injector. I'll keep you informed.
mrhart is offline  
Old 08-27-2013, 08:46 PM
  #10  
Junior Member
 
Join Date: Jul 2013
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by mrhart View Post
Spent over $1000. Got all new spark plugs, a new #7 boot(mine was bad), and 2 other BS parts replaced. I get about 1 mpg better now but still have the same issue. Im going to see about replacing my stock intake and try cleaning or replacing the fuel injector. I'll keep you informed.
Well, i took it back again just to see what they about the problem still existing and with hours of testing all they could come up with is "theres definately something still wrong with it".

Im pretty certain its got something to do with the intake, exhaust, or injection. Still gonna figure this out.
mrhart is offline  

Thread Tools
Search this Thread
Quick Reply: 5.4 Problem links.


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: