Topic Sponsor
2009 - 2014 Ford F150 General discussion on 2009 - 2014 Ford F150 truck.

A/C blower issues

 
Old 06-30-2017, 10:25 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Jun 2017
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default A/C blower issues

My A/C blower in my F-150 Platinum quit working on all speeds but one. I replaced the blower motor resistor with an after market one. It now works on all speeds but "high" speed. When you put it on high speed it blowers for a few seconds then shuts down. The resistor that I replaced says that it is for an auto control a/c but doesn't mention "dual control". I've found a motorcraft resisitor that states for "auto control" and "duel control".


I've ordered the motorcraft brand but thought someone may have some thoughts on it.
mamos is offline  
Old 07-07-2017, 12:45 PM
  #2  
Administrator
 
Lenn's Avatar
 
Join Date: Oct 2008
Location: Letterkenny, Ontario
Posts: 14,130
Received 1,169 Likes on 348 Posts
Default

I moved this to a section that may not be your year range. Please let us know what year your truck is and I'll move the thread to the appropriate section if this isn't it.
Lenn is offline  
Old 07-07-2017, 02:36 PM
  #3  
Member
 
Join Date: Aug 2011
Location: Lynnwood, WA
Posts: 66
Received 3 Likes on 3 Posts
Default

My blower just quit working all together. No speed does the fan come on. Ordered a replacement resistor as this is what my BMW did when its resistor went out.
sunnydude is offline  
Old 07-08-2017, 11:09 AM
  #4  
Member
 
Join Date: Aug 2011
Location: Lynnwood, WA
Posts: 66
Received 3 Likes on 3 Posts
Default

What part number did you get?
sunnydude is offline  
Old 07-08-2017, 12:30 PM
  #5  
Senior Member
 
doolyd's Avatar
 
Join Date: Mar 2013
Location: GOD BLESS TEXAS!
Posts: 211
Likes: 0
Received 16 Likes on 14 Posts
Default

doolyd is offline  
Old 07-08-2017, 12:47 PM
  #6  
Senior Member
 
doolyd's Avatar
 
Join Date: Mar 2013
Location: GOD BLESS TEXAS!
Posts: 211
Likes: 0
Received 16 Likes on 14 Posts
Default

Here is another long thread about this issue.

https://www.f150forum.com/f38/2013-f...issues-248650/
doolyd is offline  
 


Thread Tools
Search this Thread

Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: