Topic Sponsor
Maintenance Shop Keep your Ford F150 truck running strong. Discuss all things maintenance here.
Sponsored by:
Sponsored by:

2007 Lincoln Mark LT Stalls When Cold

 
Old 03-31-2019, 10:30 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Mar 2019
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default 2007 Lincoln Mark LT Stalls When Cold

Hi All! First time poster on this forum.

I have a 2007 Lincoln Mark LT with a 5.4 engine that was replaced app 16 months ago with a rebuilt one. Been operating great till about 2 months ago when I noticed that when I started it and ran it cold that it would stall or hesitate and then would sometimes go into fail safe mode and sometimes would say low oil pressure. No engine light comes on. I've replaced the oil pressure sensor and air filter as I've read on other forums that those could be the issues but not with mine. Could it be an oil pump? Any suggestions?? I'm probably going to have to bring it somewhere that can hook up a scanner and test it during a cold start.
Mnfish22 is offline  
Old 04-01-2019, 11:03 AM
  #2  
Senior Member
 
Join Date: Oct 2018
Location: Maysville KY
Posts: 1,494
Received 103 Likes on 99 Posts
Default

I would hook a scanner to it. something is causing the oil pump to cause the low oil pressure
DarrinT04 is offline  
 


Thread Tools
Search this Thread
Quick Reply: 2007 Lincoln Mark LT Stalls When Cold


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: