1977 F-150 Ignition module/no start - Ford F150 Forum - Community of Ford Truck Fans



1977 F-150 Ignition module/no start

Reply
 
 
 
Thread Tools Search this Thread
Old 03-18-2017, 11:01 PM   #1
Junior Member
Thread Starter
 
Join Date: Jun 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default 1977 F-150 Ignition module/no start

Hello,

New to the forum so forgive me if im not posting right. Anyways I got a 77 ford with a 460, Mallory Hei ignition and fairly stock everything else. I was out of the country for about 9 months and I had my truck sitting, ran fine before this. Well when I come back I service it all up, change the fluids, and a little sea foam for the carb and tank. Well after about a month it starts dying out of nowhere. I start it back up and it will run a little further. So I figure I am having either coil or ignition module problems. I replace both with the kit from Mallory but it came with a different type of module it's a hyfire hei module part# 699. Truck only cracks after I do this so I remove the module since it looks different than the original and put the old one back on. It start fine but dies without rhyme or reason while driving. Doesn't matter speed or rpm. Sorry for being long winded. Any help will be great!

Thanks ,
Bill
WGorden is offline   Reply With Quote
Old 09-01-2017, 10:59 AM   #2
Senior Member
 
hobolabo's Avatar
 
Join Date: Feb 2014
Location: Northern MI Lower peninsula
Posts: 128
Thanked 10 Times in 10 Posts
Default

Had same problem on a (forgive me) GM , upon checking closely inside dizzy i found a cracked wire on module that would short occasionally when it would either advance or retard.
Hope it helps.
hobolabo is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 02:07 AM.


Copyright 2006 - 2017 F150Forum.com We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: