Shudder miss '87 - Ford F150 Forum - Community of Ford Truck Fans

Topic Sponsor

Shudder miss '87

Reply

 
 
 
Old 09-06-2017, 05:59 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Aug 2017
Posts: 23
Thanks: 0
Thanked 3 Times in 3 Posts
Default Shudder miss '87

Got an 87 f150 with 4.9 smog pump deleted. I had another tread going but it was in >drivetrain and wanted more exposure. Didn't find a solution.

Brought the baby home the other week and it was running fine. The next morning went to start it and it was shaking and didn't have any power. So I brought it back home.
Replaced plug, wires, cap, rotor, fuel filter. Checked fuel pressure. Was about 45-46 cold idle, and got it to 56 giving it some throttle. Checked for vacuum leaks with carb cleaner. Didn't find any. Ohmed coil. Idk specs but have those numbers.

Checked compression like 2 weeks prior and it was all good.
Here's old thread. https://www.f150forum.com/f89/ol-red-ashakin-391118/

Got compression, air and spark. Thinking it must be fuel

​​​​​​​At this point I'm thinking injectors are clogged because of old fuel filter contents, it was black and... Idk coffeeish?
Kentuckysix is offline  
Reply With Quote
The Following User Says Thank You to Kentuckysix For This Useful Post:
MidSouthMitch (09-15-2017)
Old 09-08-2017, 05:27 AM
  #2  
Senior Member
 
Join Date: Oct 2016
Location: Ohio
Posts: 256
Thanks: 0
Thanked 37 Times in 31 Posts
Default

Another quick check: make sure your EGR valve isn't stuck open. Might even try a quick whack to it with a hammer. These can be a pain to get off.
raski is offline  
Reply With Quote
The Following User Says Thank You to raski For This Useful Post:
MidSouthMitch (09-15-2017)
Old 09-08-2017, 07:34 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Aug 2017
Posts: 23
Thanks: 0
Thanked 3 Times in 3 Posts
Default

As of now I have the intake partially disassembled trying to get to injectors. The egr tube is rusted on. Probably gonna bust it, install a block off plate.
Kentuckysix is offline  
Reply With Quote
The Following User Says Thank You to Kentuckysix For This Useful Post:
MidSouthMitch (09-15-2017)
Old 09-11-2017, 08:49 PM
  #4  
Junior Member
Thread Starter
 
Join Date: Aug 2017
Posts: 23
Thanks: 0
Thanked 3 Times in 3 Posts
Default

Got fuel rail off. Took off the injectors, they came out easier than I expected. Last injectors I helped remove was from an lb7 and we're alot harder lol. Soaked they in B12 chemtool for a day. Rigged up an injector harness to a 9v and blew it out with air. One injector didn't open. Assume I found the culprit.
Kentuckysix is offline  
Reply With Quote
The Following User Says Thank You to Kentuckysix For This Useful Post:
MidSouthMitch (09-15-2017)
 
 
 


Thread Tools
Search this Thread

Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: