Timing chain broke on ecoboost - Ford F150 Forum - Community of Ford Truck Fans



2011+ Engine Related Questions Sub-Forum to the new engines that debuted in 2011.

Timing chain broke on ecoboost

Closed Thread
 
 
 
Thread Tools Search this Thread
Old 04-30-2012, 01:20 AM   #1
Junior Member
Thread Starter
 
Join Date: Apr 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Timing chain broke on ecoboost

Hello, I'm new to the forum and was looking to see if anyone's had any similar issues.
I bought my 2011 ecoboost f150 in July 2011. To date I have been into the shop for the transmission pump recall, engine seal leaks on the front end, and most recently the timing chain broke and destroyed my engine.
Has anybody had these problems or am I the only one?
Thanks
Jason
MechJay is offline  
Old 04-30-2012, 04:15 AM   #2
Senior Member
 
Join Date: Jul 2011
Posts: 172
Thanked 9 Times in 8 Posts
Default

Transmission was a pretty big blowup on here before the recall went out. I have never heard of the timing chain breaking on these. I know the hydro adjuster on them only has 10 teeth for adjustment before the chain is stretched out of "serviceability". Yours just broke though? Can we get a scenario of when it broke on you?
killerrudy is offline  
Old 04-30-2012, 09:58 AM   #3
Senior Member
 
Join Date: Nov 2011
Location: Las Vegas
Posts: 3,620
Thanked 458 Times in 309 Posts
Default

Quote:
Originally Posted by killerrudy
Transmission was a pretty big blowup on here before the recall went out. I have never heard of the timing chain breaking on these. I know the hydro adjuster on them only has 10 teeth for adjustment before the chain is stretched out of "serviceability". Yours just broke though? Can we get a scenario of when it broke on you?
It was only I/E/tuned and on a 150 shot.... Jk
jcain is offline  
Old 04-30-2012, 10:52 AM   #4
Senior Member
 
02themax's Avatar
 
Join Date: May 2011
Location: Calgary, AB Canada
Posts: 547
Thanked 14 Times in 14 Posts
Default

Yes more info needed please, were you towing/racing? How many miles etc...?
02themax is offline  
Old 04-30-2012, 11:44 AM   #5
Junior Member
Thread Starter
 
Join Date: Apr 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The heaviest load I've towed was a 5000lb trailer and that's when the tranny seal failed. I also tow a sled trailer. Truck is completely stock with 21000km on it. When it happened the check engine light came on and I was almost home, lost all power then heard some grinding and it died. There was no trailer being towed at the time
MechJay is offline  
Old 04-30-2012, 01:39 PM   #6
Senior Member
iTrader: (1)
 
Join Date: Jul 2011
Location: South Texas
Posts: 332
Thanked 17 Times in 8 Posts
Default

Good thing its covered by warranty, I wonder how your timing chain failed. Let us know how many valves your engine ate.
ninjatalon is offline  
Old 01-11-2014, 05:30 PM   #7
Junior Member
 
Join Date: Jan 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have a 2011 ecoboost and timing chain slipped and causing all my valve heads to bend and destroyed my engine $6000 to rebuild or $13500 to buy new one warranty for 100,000 kms died at 133,625 kms. how many others are running into this problem?
jusmar2112 is offline  
Old 01-11-2014, 07:36 PM   #8
Senior Member
 
papa tiger's Avatar
 
Join Date: Nov 2011
Posts: 21,507
Thanked 197 Times in 187 Posts
Default

Right with 1 post, I feel for U. Hope warranty takes care of it.
papa tiger is online now  
Old 01-12-2014, 12:02 PM   #9
Junior Member
 
Chris74's Avatar
 
Join Date: Jan 2014
Posts: 14
Thanks: 0
Thanked 36 Times in 6 Posts
Default

.....see the thread I posted on timing chains above (Broken timing chains - 2011 Ecoboosts)

Yes - Some of us are starting to have a serious problem with timing chains!
Chris74 is offline  
Old 01-12-2014, 12:18 PM   #10
Senior Member
 
Join Date: Feb 2011
Location: Maine
Posts: 2,230
Thanked 349 Times in 228 Posts
Default

I've got to think there was a defect in the material for it to have broken that quickly. Even if others are starting to have problems (which is not something i had heard before this thread).
11screw50 is offline  
 
 
Closed Thread

Related Topics
Thread Thread Starter Forum Replies Last Post
2015 2.7L Ecoboost Issue? Jdcanter13 6 Cylinder Engines 48 11-22-2016 12:25 PM
New here and long time F150 Owner Texas_XLT Introductions 4 05-21-2016 10:39 AM
2015 or Wait for 2016 blackout44 General F150 Discussion 17 02-28-2016 02:45 AM
Platinum 5.0 oil color and level Takeda 2015 - Present Ford F150 17 09-05-2015 10:20 PM
New member from VA! VA10 Introductions 0 09-03-2015 09:02 AM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 09:48 PM.


Copyright 2006 - 2017 F150Forum.com
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: