Topic Sponsor
Aftermarket Products, Reviews & Installation Discuss modifications and enhancements to your Ford F150.
Sponsored by:
Sponsored by:

roush boost gauge not lighting up??

 
Old 06-09-2019, 12:56 PM
  #1  
Member
Thread Starter
 
Join Date: Aug 2014
Location: Burlington Ontario
Posts: 56
Likes: 0
Received 5 Likes on 5 Posts
Default roush boost gauge not lighting up??

So I bought a boost gauge for my 2013 3.5l.
as always, before an install, I bench test it to make sure I'm not installing a faulty product. I can get the needle to power up (red) but not the backlight for the gauge face. Neither the white nor blue lights seemed to work. Called Roush and they sent me another right away but after doing the same test, no backlight....
am I missing something?

I've tried all combinations of wires, jumping the red with the white and or blue, to no avail.
Really would like to install this gauge but would like to figure this out first.
All circuits have continuity with ground (on both gauges)
That's about the extent of my electrical knowledge.
teeko is offline  
 


Thread Tools
Search this Thread
Quick Reply: roush boost gauge not lighting up??


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: