2004 5.4 3v dying when coming to stop, or turning slow corners - Ford F150 Forum - Community of Ford Truck Fans

Go Back  Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
2004 5.4 3v dying when coming to stop, or turning slow corners >

2004 5.4 3v dying when coming to stop, or turning slow corners

Topic Sponsor
2004 - 2008 Ford F150 General discussion on the 2004 - 2008 Ford F150 truck.

2004 5.4 3v dying when coming to stop, or turning slow corners

Old 05-16-2018, 02:41 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Nov 2017
Posts: 22
Thanked 2 Times in 2 Posts
Default 2004 5.4 3v dying when coming to stop, or turning slow corners



I just did a timing/cam phasers job on my 04 5.4 f150. Everything went great. Starts and idles perfect. The problem is that when I am driving it and come to a stop sign, or stop light, it dies. It will start right back up and runs great. It also does it if I am turning slowly, like into a driveway. I have replaced plugs and coil packs as well. I have no CEL. Any advice on what to do? Bad injector? I ran sea foam through it. Trying to keep from taking it to the dealership. Thanks in advance. it will also stutter real bad when it shifts between 3rd and drive. If I get on the gas, it goes away.
Fatherofthree13 is offline  
Old 05-16-2018, 05:10 PM
  #2  
Member
 
Join Date: Feb 2018
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Default

Mine did this before I put a new engine in. It was getting low oil pressure. I'd have the oil pressure checked. You didn't swap out the oil pump while in there?
tommyboy180 is offline  
Old 05-16-2018, 05:25 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Nov 2017
Posts: 22
Thanked 2 Times in 2 Posts
Default

New oil pump installed and installed an actual oil pressure gauge. I am getting plenty of oil pressure.
Fatherofthree13 is offline  
Old 05-16-2018, 05:29 PM
  #4  
Member
 
Join Date: Feb 2018
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Default

Originally Posted by Fatherofthree13 View Post
New oil pump installed and installed an actual oil pressure gauge. I am getting plenty of oil pressure.
That's awesome. I wish these trucks came with an actual pressure gauge.

Does the truck behave the same with the VCT's disconnected?
tommyboy180 is offline  
Old 05-16-2018, 06:30 PM
  #5  
Junior Member
Thread Starter
 
Join Date: Nov 2017
Posts: 22
Thanked 2 Times in 2 Posts
Default

That is something I havenít checked yet. Thanks for a direction to move to. I am questioning the injectors, but am unfamiliar with how to check them.

Originally Posted by tommyboy180 View Post
That's awesome. I wish these trucks came with an actual pressure gauge.

Does the truck behave the same with the VCT's disconnected?
Fatherofthree13 is offline  
Old 05-16-2018, 09:29 PM
  #6  
Senior Member
 
LariatDude's Avatar
 
Join Date: Feb 2017
Location: Melbourne, Florida
Posts: 620
Thanked 29 Times in 29 Posts
Default

Ooooo he's got a good point, unplug the VCTs and drive it. What are the chances you replaced those?
LariatDude is offline  
Old 05-16-2018, 09:50 PM
  #7  
Junior Member
Thread Starter
 
Join Date: Nov 2017
Posts: 22
Thanked 2 Times in 2 Posts
Default


This is the kit I installed. All OEM from Freedom Racing. I will unplug the vcts tomorrow and see what happens. Everything is new, itís keeping me from driving the truck because of it dying at every stop light. The missfire going into overdrive is also very concerning.

Last edited by Fatherofthree13; 05-16-2018 at 11:12 PM. Reason: Wrong purchase place
Fatherofthree13 is offline  
Old 05-17-2018, 04:33 PM
  #8  
Senior Member
 
Join Date: Aug 2015
Location: Jackson, NJ
Posts: 525
Thanked 48 Times in 41 Posts
Default

I've had this issue in the past. Cleaning the TB fixed it for me. Just get some TB cleaner and wipe the gunk out of there with a rag.
ReaperHWK is offline  
Old 05-17-2018, 07:39 PM
  #9  
Member
 
PALMETTO_XLT's Avatar
 
Join Date: Jan 2012
Location: CHARLESTON SC
Posts: 65
Thanks: 0
Thanked 5 Times in 5 Posts
Default

Originally Posted by Fatherofthree13 View Post

This is the kit I installed. All OEM from Freedom Racing. I will unplug the vcts tomorrow and see what happens. Everything is new, itís keeping me from driving the truck because of it dying at every stop light. The missfire going into overdrive is also very concerning.
If that is the same kit im thinking of they replaced certain items with aftermarket parts. It was in the fine print.

I would check VCT like mentioned above. Sounds a lot like they could be the culprit.
PALMETTO_XLT is offline  
Old 05-17-2018, 08:13 PM
  #10  
05 5.4l 3v s.crew lariat
 
redfishtd's Avatar
 
Join Date: Oct 2009
Location: fl
Posts: 1,971
Thanked 266 Times in 249 Posts
Default Yes take tb off and clean it ,clean maf with proper cleaner

But you need some evidence after that . If you have android phone get 5 dollar torque pro and cheap amazon bluetooth reader . It will tell a lot even going down the road . It gives you raw data like misfire counts that are short of cel threshold by cyl so you can keep an eye on it . It will give you fuel trims etc . A bad injector shouldn't do this . You will get to see your o2 sensors and the raw volts changing .Right now you are flying blind .
Cleaning tb is always a good idea but it won't fix a bad motor or circuit board on it either which happened to me .
redfishtd is offline  

Thread Tools
Search this Thread
Quick Reply: 2004 5.4 3v dying when coming to stop, or turning slow corners


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: