Topic Sponsor
Maintenance Shop Keep your Ford F150 truck running strong. Discuss all things maintenance here.
Sponsored by:
Sponsored by:

Water pump - Radiator Problem

 
Old 04-02-2019, 06:52 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Apr 2019
Location: Austin TX
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default Water pump - Radiator Problem

Replaced a leaking water pump on my 2013 w 5ltr engine. New pump, t'stat, upper hose and fluid. Then the radiator fans started running on high. Just checked under the hood and found that the radiator fins feel cool to the touch, the lower hoses feel fairly cool and the upper radiator hose is hot. Any thoughts on what the problem is would be greatly appreciated!
Fred Helmerichs is offline  
Old 04-03-2019, 12:48 AM
  #2  
Senior Member
 
20004.6's Avatar
 
Join Date: Nov 2012
Location: California
Posts: 191
Likes: 0
Received 27 Likes on 24 Posts
Default

possibly air pocket in system. did you install an OEM T-stat? Several people on here are having issues with aftermarket t-stats on these 5.0
20004.6 is offline  
Old 04-03-2019, 07:31 AM
  #3  
Junior Member
Thread Starter
 
Join Date: Apr 2019
Location: Austin TX
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

It was an aftermarket - will install an OEM. Thanks for the follow up.
Fred Helmerichs is offline  
 


Thread Tools
Search this Thread
Quick Reply: Water pump - Radiator Problem


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: