07 5.4 lack of power - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
Log In 


07 5.4 lack of power

Reply
 
 
 
 
Thread Tools Search this Thread
Old 07-28-2014, 11:46 PM   #1
Junior Member
 
Join Date: Apr 2014
Posts: 25
Feedback Score: 0 reviews
Thanks: 0
Thanked 1 Time in 1 Post
Default 07 5.4 lack of power

Ok so my 07 supercrew 2wd 5.4 runs fine...but i just did a level 20's and 35x12.5's. And cruising around town its fine but when i get in highway every hill shes kickin down a gear or 2. Would a programmer fix this issue or am i stuck with it shifting constantly? Heres a pic if truck


07 5.4 lack of power-forumrunner_20140728_224337.jpg
joinerboy is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 07-29-2014, 12:44 AM   #2
Bleeding Ford Blue
 
Summers22's Avatar
 
Join Date: Feb 2014
Posts: 4,902
Feedback Score: 1 reviews
Thanked 535 Times in 435 Posts
Default

I would focus on a tune-up of plugs, COP boots, fuel filter, clean throttle body and MAF, then look into and Edge Evolution or SCT.

I like your stance, but one question, you only did a level kit on the front and fit 35" tires?
Summers22 is offline   Reply With Quote
Old 07-29-2014, 12:51 AM   #3
Junior Member
 
Join Date: Apr 2014
Posts: 25
Feedback Score: 0 reviews
Thanks: 0
Thanked 1 Time in 1 Post
Default

Yea rough country 2.5" level in front w 1" blocks in rear w new shocks from rough country also. It rubs a little when in a parking lot but thats bc of my wheel spacing. Ive already done cop boots. Need to do plugs but im scared lol
joinerboy is offline   Reply With Quote
Old 07-29-2014, 12:56 AM   #4
Bleeding Ford Blue
 
Summers22's Avatar
 
Join Date: Feb 2014
Posts: 4,902
Feedback Score: 1 reviews
Thanked 535 Times in 435 Posts
Default

Dont be scared of the plugs, I had the Lisle tool on hand, removed the plugs after the engine warmed up and broke none at 113K. I did run a full bottle of Seafoam through the gas tank for 200 miles before hand to help break up some carbon.
Summers22 is offline   Reply With Quote
 
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need audio experts! Kalen427 Stereo/Audio 34 01-24-2016 04:54 PM
Chirp/sqeal With No Drive Belt I'dRatherBfishing General F150 Discussion 2 01-06-2016 06:03 PM
Changed vct solenoids at 151k engine tick went away redfishtd 2004 - 2008 Ford F150 21 12-31-2015 12:25 AM
North Central: 2009-2014 XLT Ford OEM Tow Mirrors yamahatim 2009 - 2014 Part Sales 6 09-12-2015 11:46 PM
tired 5.4....more power? cheap? hartfordf150 1997 - 2003 Ford F150 18 09-11-2015 03:54 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 08:33 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.