Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2004 - 2008 Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 07-28-2014, 10:46 PM   #1
Junior Member
 
Join Date: Apr 2014
Posts: 8
Mentioned: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default 07 5.4 lack of power

Ok so my 07 supercrew 2wd 5.4 runs fine...but i just did a level 20's and 35x12.5's. And cruising around town its fine but when i get in highway every hill shes kickin down a gear or 2. Would a programmer fix this issue or am i stuck with it shifting constantly? Heres a pic if truck


07 5.4 lack of power-forumrunner_20140728_224337.jpg
joinerboy is offline   Reply With Quote
Old 07-28-2014, 11:44 PM   #2
Bleeding Ford Blue
 
Summers22's Avatar
 
Join Date: Feb 2014
Location: Kansas
Posts: 1,247
Mentioned: 1 Post(s)
Thanks: 47
Thanked 92 Times in 79 Posts
Feedback Score: 0 reviews
Default

I would focus on a tune-up of plugs, COP boots, fuel filter, clean throttle body and MAF, then look into and Edge Evolution or SCT.

I like your stance, but one question, you only did a level kit on the front and fit 35" tires?
Summers22 is offline   Reply With Quote
Old 07-28-2014, 11:51 PM   #3
Junior Member
 
Join Date: Apr 2014
Posts: 8
Mentioned: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

Yea rough country 2.5" level in front w 1" blocks in rear w new shocks from rough country also. It rubs a little when in a parking lot but thats bc of my wheel spacing. Ive already done cop boots. Need to do plugs but im scared lol
joinerboy is offline   Reply With Quote
Old 07-28-2014, 11:56 PM   #4
Bleeding Ford Blue
 
Summers22's Avatar
 
Join Date: Feb 2014
Location: Kansas
Posts: 1,247
Mentioned: 1 Post(s)
Thanks: 47
Thanked 92 Times in 79 Posts
Feedback Score: 0 reviews
Default

Dont be scared of the plugs, I had the Lisle tool on hand, removed the plugs after the engine warmed up and broke none at 113K. I did run a full bottle of Seafoam through the gas tank for 200 miles before hand to help break up some carbon.
Summers22 is offline   Reply With Quote
Old 07-28-2014, 11:56 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 03:56 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.