Strange problem! - Ford F150 Forum - Community of Ford Truck Fans



Strange problem!

Reply
 
 
 
Thread Tools Search this Thread
Old 12-03-2013, 07:20 PM   #1
Member
Thread Starter
 
Join Date: Dec 2012
Location: Red Deer, Alberta, Canada
Posts: 89
Thanked 5 Times in 5 Posts
Default Strange problem!

So i was going through a drive through car wash today with my 2012 5.0,it seemed as soon as i started driving through the mist of water my truck started revving up and down on its own like from idle up to 1500. just up and down up and down. So i shut it off, started it back up (while still in the car wash with water spraying) and it didn't do it again. No engine light, no errors or anything, and it hasn't done it since.

Any of you have an explanation for what this may be. I know for a fact if i bring it to the dealer i will get the ( test drove and no issues were found) bs they give everyone with vehicles still on warranty.
5.0FX4OFFROAD is offline   Reply With Quote
Old 12-03-2013, 07:43 PM   #2
Senior Member
 
Azuri's Avatar
 
Join Date: Apr 2013
Location: Ontario, Canada
Posts: 1,744
Thanked 474 Times in 330 Posts
Default

There is a TSB to flash the PCM.

http://www.fordservicecontent.com/pu...sb13-01-10.pdf

Here's a thread discussing it.

http://www.f150forum.com/f70/2012-f1...urging-176922/
Azuri is offline   Reply With Quote
Old 12-06-2013, 05:35 PM   #3
Ford Customer Service

 
FordServiceCA's Avatar
 
Join Date: Jul 2013
Location: Oakville, ON
Posts: 362
Thanked 33 Times in 27 Posts
Default

Quote:
Originally Posted by 5.0FX4OFFROAD View Post
So i was going through a drive through car wash today with my 2012 5.0,it seemed as soon as i started driving through the mist of water my truck started revving up and down on its own like from idle up to 1500. just up and down up and down. So i shut it off, started it back up (while still in the car wash with water spraying) and it didn't do it again. No engine light, no errors or anything, and it hasn't done it since.

Any of you have an explanation for what this may be. I know for a fact if i bring it to the dealer i will get the ( test drove and no issues were found) bs they give everyone with vehicles still on warranty.
Hi 5.0FXOFFROAD,

I previously engaged with you on a thread offering my assistance; I would still like to look into this for you. Please send me a private message with your VIN, odometer reading, full name, and phone number. If I remember correctly, your servicing dealer was Thorncrest Ford. If you have switched to another one, please let me know which.

Also, before sending me this information, make you sure you take an appointment with your dealer at your earliest convenience. Once that is done, please get back to me with the information requested above along with your appointment's date and time so I can loop in your customer service manager.

Bianca
FordServiceCA is offline   Reply With Quote
Old 12-06-2013, 05:38 PM   #4
POWWWERRR!!!!!
 
dieselhunter44's Avatar
 
Join Date: Dec 2012
Posts: 1,150
Thanked 158 Times in 112 Posts
Default

Your 5.0 obviously tried to go into Ecoboost mode!

THAT WAS A JOKE! I am 100% kidding

Hopefully you get it worked out
dieselhunter44 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rough Idle/Misfiring - HELP! (2006 F150 5.4L v8) carp104 2004 - 2008 Ford F150 39 08-09-2016 07:32 PM
Aluminum Problems wpbritton General F150 Discussion 11 03-20-2016 09:39 PM
Need help! Battery keeps dying! john367 2009 - 2014 Ford F150 42 10-23-2015 03:23 PM
Transmission problems P0720,P0722 azkfx450 2004 - 2008 Ford F150 2 09-11-2015 12:52 PM
New to me truck with problems--please help!! AKJT1215 2004 - 2008 Ford F150 13 09-09-2015 06:01 AM


Tags
revving 5.0

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 08:29 PM.


Copyright 2006 - 2016 F150Forum.com