Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2009 - Present Ford F150
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 02-20-2013, 01:08 PM   #2361
Junior Member
 
Join Date: Feb 2013
Location: Texas
Posts: 5
Mentioned: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I am thinking about calling. My truck has been in the shop for 3 weeks yesterday and the customer service person at Ford said yesterday she was tryingto get my parts to the dealer late next week. That's a month sooner than my service advisor thought. It frustrates me that this is the 3rd time my truck has been in and we are not 100% convinced this is going to fix it. Add the safety concerns, potential increased depreciationof the ecoboost motors if they don’t get it resolved not to mention my mileage has never lived up to the window sticker claims. On the other hand the dealer has been fairly good to me. They gave me a new F150 5.0 to drive. Some members are still driving their trucks with the check engine light on waiting for parts.

I do find it hard to believe this didn’t come out in their preproduction tests. Not sure when you guys first started having the issues with your trucks, but this thread was started 5 months BEFORE I bought my truck. My guess is the only one that is going to get paid on the class action suit is the attorneys, but what would it hurt to have my case included? Doubt Ford is going to black list me and deny my future warrantee work because my name was on the list.

I am interested to hear the rest of your thoughts and if you’re going to join. I assume it does not costanything to join?

On a side note. I had been lurking here for a few months before joining a few weeks ago and am really enjoying the site. I am a member of a few gun sites, but the tension on them is getting to people. It’srefreshing to read threads without constant petty arguments or rude comments taking up half the thread.
Sorry for the long post!

Last edited by carsandguns; 02-20-2013 at 01:11 PM.
carsandguns is offline   Reply With Quote
Old 02-21-2013, 10:44 AM   #2362
One Bad MoFoMoCo Owner
 
sullyman's Avatar
 
Join Date: Jul 2012
Location: Texas Hill Country
Posts: 2,225
Mentioned: 6 Post(s)
Thanks: 605
Thanked 390 Times in 256 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by Subduedracer View Post
I have what may seem as a left field questions. I have only had the limp mode issue one time with my truck. It is the ECO. I went to a car wash for the first time the day before and it sprayed underneath. I wonder if the two are connected?
Hey Geno, I'm not making this crap up. Here's one more, and there's other threads with this too.
__________________
2012 Ford F150 5.0 "Coyote" SCrew 4x4 XLT, American Tonneau Trifold Soft Cover, Bedrug, Kenwood 6x8s all around, Kenwood DDX Headunit, 10" Kenwood Excelon 1400 watt Subwoofer in custom box powered by 1,000 watt Kenwood Mono Amp, Wolo Airhorns, Stainless 5" Widetread Nerf bars, Chrome Door and Tailgate latch covers, license plate mounted reverse camera.
sullyman is offline   Reply With Quote
Old 02-21-2013, 11:32 AM   #2363
Senior Member
 
f150man3.5's Avatar
 
Join Date: Dec 2011
Location: ontario
Posts: 906
Mentioned: 0 Post(s)
Thanks: 97
Thanked 70 Times in 52 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by sullyman View Post

Hey Geno, I'm not making this crap up. Here's one more, and there's other threads with this too.
That says he went to a car wash and sprayed underneath....and at some point had a limp mode issue....too much missing info to even remotely they are related
__________________
2011 XLT ECOBOOST
f150man3.5 is offline   Reply With Quote
The Following User Says Thank You to f150man3.5 For This Useful Post:
geno51 (02-21-2013)
Old 02-21-2013, 12:12 PM   #2364
Senior Member
 
Join Date: Jul 2011
Location: Tollhouse, Ca
Posts: 135
Mentioned: 0 Post(s)
Thanks: 7
Thanked 9 Times in 8 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by geno8769 View Post
I will be calling this AM. Since Ford has been thoroughly non responsive.
I threw my name in the hat via email. It said it was open to FORMER owners too and I am one of those. Ford basically told me "eff you" so this is my way of saying "eff you" back. I don't even care if I get anything out of the class action suit or not. All my ex ecoboost is to me is a bad memory and a file folder full of paperwork.
OlderThanSand is offline   Reply With Quote
The Following 2 Users Say Thank You to OlderThanSand For This Useful Post:
canddmeyer (02-21-2013), Riccochet (02-21-2013)
Old 02-21-2013, 06:24 PM   #2365
Senior Member
 
Tyssa'sRide's Avatar
 
Join Date: Nov 2011
Posts: 873
Mentioned: 0 Post(s)
Thanks: 24
Thanked 57 Times in 36 Posts
Feedback Score: 0 reviews
Default

Well after waiting since mid November I finally got a call from the dealer saying my intercooler is in. She told me they got 3 in today. And they say they have never heard of the problem before..... Interesting that they show up a couple days after we all hear about the class action. Could be coincidence LOL.
Tyssa'sRide is online now   Reply With Quote
Old 02-21-2013, 07:04 PM   #2366
Haulin Bass!
 
Riccochet's Avatar
 
Join Date: Jun 2011
Location: Concord, NC
Posts: 700
Mentioned: 0 Post(s)
Thanks: 11
Thanked 40 Times in 28 Posts
Feedback Score: 0 reviews
Default

I joined the class action. FOR BOTH OF MY PIECES OF TIHS EB F150's. The 2011 that was lemoned and my current 2012 that's about to be lemoned. FML
__________________
2012 F150 SCAB EB (SOLD!)
Riccochet is offline   Reply With Quote
Old 02-21-2013, 07:14 PM   #2367
Senior Member
 
TwinTurboFx4's Avatar
 
Join Date: Jul 2011
Posts: 4,254
Mentioned: 1 Post(s)
Thanks: 133
Thanked 104 Times in 96 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by riccochet View Post
i joined the class action. For both of my pieces of tihs eb f150's. The 2011 that was lemoned and my current 2012 that's about to be lemoned. Fml
bad luck
TwinTurboFx4 is offline   Reply With Quote
Old 02-21-2013, 10:03 PM   #2368
Senior Member
 
geno51's Avatar
 
Join Date: Jul 2011
Location: Prescott AZ
Posts: 2,864
Mentioned: 0 Post(s)
Thanks: 480
Thanked 427 Times in 261 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by f150man3.5 View Post

That says he went to a car wash and sprayed underneath....and at some point had a limp mode issue....too much missing info to even remotely they are related
Haha major reaching!!
__________________
2012 Fx4 EB Screw 3.73 EL 5.5 bed. Full Race SCTtune,Full Race Intercooler, Full Race 3" Exhaust, Afe stage2 CAI,Bilinvic custom FXR 3" retro 55w 5k headlights Custom indash 9" android tablet
geno51 is offline   Reply With Quote
Old 02-22-2013, 06:37 AM   #2369
Senior Member
 
Join Date: Oct 2012
Location: Maryland
Posts: 202
Mentioned: 0 Post(s)
Thanks: 4
Thanked 9 Times in 7 Posts
Feedback Score: 0 reviews
Default Just don't understand

Quote:
Originally Posted by Riccochet View Post
I joined the class action. FOR BOTH OF MY PIECES OF TIHS EB F150's. The 2011 that was lemoned and my current 2012 that's about to be lemoned. FML
Riccochet, why did you buy another Eco after the 2011 Ecoboost was returned under the lemon law? I am at a loss to understand why anyone would even look at another ecoboost after what you went through.
__________________
2013 F150 XLT 4X4, regular cab with 8' bed and 3.5L Ecoboost engine. Ordered with the 3:73 limited slip differential and HD Payload of 2731lbs with 245/75R17 Load range E tires. Also has the max towing package in Ingot Silver.
GM Guy is offline   Reply With Quote
Old 02-22-2013, 12:39 PM   #2370
Senior Member
 
Join Date: Dec 2012
Posts: 2,576
Mentioned: 5 Post(s)
Thanks: 101
Thanked 498 Times in 344 Posts
Feedback Score: 0 reviews
Default

Quote:
It’srefreshing to read threads without constant petty arguments or rude comments taking up half the thread.
What forum are you reading? Can't be the same one I've been on.

packplantpath is offline   Reply With Quote
Old 02-22-2013, 12:39 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Miss at idle and 60MPH. Need help please. JC316 1987 - 1996 F150 6 10-11-2012 01:17 AM
2011 Shuddering Poll Bob_Mac 2009 - Present Ford F150 44 04-20-2012 09:37 AM
I-6 Lagging at 60mph?? flaresf150 1987 - 1996 F150 0 11-06-2011 02:47 PM
2011 Ford Raptor 0-60MPH OutlawFord 2009 - Present Ford F150 5 05-20-2011 12:22 PM
vibrating at 55-60mph??? vtprairie03 1997 - 2003 Ford F150 4 02-26-2010 11:27 PM

Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 01:48 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.