Go Back   Ford F150 Forum - Community of Ford Truck Fans > Ford F150 Forums > Aftermarket Products, Reviews & Installation > Stereo/Audio
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 08-28-2014, 03:59 AM   #1
Junior Member
 
Join Date: Aug 2014
Posts: 4
Mentioned: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default Disappointed with stereo upgrade.

Just spent a pile of money on a new stereo and am thoroughly disappointed. I have a 2014 super crew with the Sony system and nav. I wanted to keep nav. And dash stock but had a local shop install the following: jl audio stealthbox, focal 165v15's for the fronts, focal 130v15's for the rears, audison bitone signal processor, audison av5.1k amplifier. All of this is tied into the sony system via the bitone processor to my knowledge. The end result is the system will do high end treble until my ears bleed and not much else. There is some mid range and some low end bass but you have to max out the volume to get there. It just sounds really thin and high pitched. There is little or no warmth to the sound at all. I would of thought a 13" jl audio sub would pressurize the cab, not even close! Is it the sony system doing this? After a big discount I still have 5k invested in this thing. Any info or insight guys??
Grindboy is offline   Reply With Quote
Old 08-28-2014, 09:50 AM   #2
Member
 
Aggie15's Avatar
 
Join Date: Apr 2013
Location: College Station, TX
Posts: 44
Mentioned: 0 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Default

Does your sound processor sum the signals? all the speaker signals need to be summed together, there is a thread somewhere on here that I used for instructions
Aggie15 is offline   Reply With Quote
Old 08-28-2014, 10:30 AM   #3
Senior Member
 
Join Date: Jul 2011
Location: Casper, WY.
Posts: 1,761
Mentioned: 0 Post(s)
Thanks: 23
Thanked 113 Times in 109 Posts
Feedback Score: 0 reviews
Default

They don't have the Bitone configured correctly. You have great equipment and will sound great when done correctly
__________________
2014 Tuxedo Black F150 XLT Scab 4x4 w/5.0 with SCT tune
Wyo11Scab is offline   Reply With Quote
Old 08-28-2014, 05:51 PM   #4
Junior Member
 
Join Date: Dec 2013
Posts: 14
Mentioned: 0 Post(s)
Thanks: 0
Thanked 2 Times in 1 Post
Feedback Score: 0 reviews
Default

Sorry your having issues with your nice system. I have a dumb question. How do they get those speakers to fit your system? Ours are oval are they not?
KodeBrown is offline   Reply With Quote
Old 08-28-2014, 05:57 PM   #5
Senior Member
 
Join Date: Jul 2011
Location: Casper, WY.
Posts: 1,761
Mentioned: 0 Post(s)
Thanks: 23
Thanked 113 Times in 109 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by KodeBrown View Post
Sorry your having issues with your nice system. I have a dumb question. How do they get those speakers to fit your system? Ours are oval are they not?
They make speaker adapters
__________________
2014 Tuxedo Black F150 XLT Scab 4x4 w/5.0 with SCT tune
Wyo11Scab is offline   Reply With Quote
Old 08-28-2014, 09:29 PM   #6
Member
 
Join Date: Jul 2013
Location: Pinellas Park, FL
Posts: 75
Mentioned: 0 Post(s)
Thanks: 6
Thanked 8 Times in 8 Posts
Feedback Score: 0 reviews
Default

Agreed with everyone here.some adjustments should make it sound phenomenal.
__________________
2013 F150 FX2 5.0 Screw, 401a, 3.55 ELD-that is all
2011 Expedition XLT 202package-superchips cortex (wife's now)
2006 Expedition EB 4x4 (you served us well)
previous 2003 F150 Supercrew (love the Expy, but still missed, if only you were 4x4)
1987 Ranger 4x4 (RIP)
mtondreo is offline   Reply With Quote
Old 08-28-2014, 10:11 PM   #7
Gimpy
 
48ford's Avatar
 
Join Date: Jun 2014
Location: Winnipeg, Mb
Posts: 48
Mentioned: 0 Post(s)
Thanks: 12
Thanked 5 Times in 4 Posts
Feedback Score: 0 reviews
Default

I have the bit ten in my truck and it took days for me to configure it to my liking. You need to download the software on your laptop, bring it into the truck and plug in the bit one and start tuning. You'll have to set, in the program, all your crossovers, master volume, channel gains, etc. to your liking and your type of music, and obviously to the speakers your running. Don't forget to save and write to the bit 1. Also double check your amp gains and crossovers. It's not an easy process but we'll worth the time in the end. What did they use for inputs? Unfortunately just cause they can install it, doesn't mean they know how to set everything up, properly. With your equipment, you should have outstanding sound quality. I am running the bit ten, focal k2p, jl 10tw3, jl xd600/1, jl xd200/2, jl xd700/5. Similar set up with factory nav.

Last edited by 48ford; 08-28-2014 at 10:17 PM.
48ford is offline   Reply With Quote
Old 08-28-2014, 10:43 PM   #8
Junior Member
 
Join Date: Aug 2014
Posts: 4
Mentioned: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

I am taking the truck back to the shop tomorrow for further analysis. The shop is a audison/focal dealer and they supposedly "tuned" it after it was installed. I of course was not there for any of it. It's got to be something like an eq adjustment with the bitone. It's so tinny, hollow, and lifeless right now. There is no warmth to it at all. The mounted the bitone under the console too so they would have to pull everything apart. I made up a cd to go off of which consists of rock, metal and techno. Surely this can be solved, even if I have to spend some more cash for fine tuning.
Grindboy is offline   Reply With Quote
Old 08-29-2014, 12:04 AM   #9
Gimpy
 
48ford's Avatar
 
Join Date: Jun 2014
Location: Winnipeg, Mb
Posts: 48
Mentioned: 0 Post(s)
Thanks: 12
Thanked 5 Times in 4 Posts
Feedback Score: 0 reviews
Default

They should have left the USB cable somewhere accessible, whether it's for you or them to fine tune. It's all done on the laptop so as long as that cable is accessible they shouldn't rip the truck apart again. Good luck. It does take time so make sure your patient. Keep us updated.
48ford is offline   Reply With Quote
Old 08-29-2014, 12:05 AM   #10
Junior Member
 
Join Date: Aug 2014
Posts: 4
Mentioned: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Default

Thanks guys! I will let you know how it goes.
Grindboy is offline   Reply With Quote
Old 08-29-2014, 12:05 AM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 06:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.