Ford F150 Forum - Community of Ford Truck Fans - Search Results



Showing results 1 to 6 of 6
Search took 0.06 seconds.
Search: Posts Made By: scanjet4300
Forum: Off-Road Section 06-17-2014, 04:34 PM
Replies: 30
Views: 4,520
Posted By scanjet4300
that's for sure!

that's for sure!
Forum: Members Builds 06-11-2014, 04:42 PM
Replies: 119
Views: 33,604
Posted By scanjet4300
that's what I have been thinking of putting on my...

that's what I have been thinking of putting on my truck, just wasn't sure if I wanted the 4" or 6" but looking at your truck i'd say 4" is perfect!
Forum: Off-Road Section 06-10-2014, 04:40 PM
Replies: 30
Views: 4,520
Posted By scanjet4300
I have a set of 33" Toyo Open Country A/T and I...

I have a set of 33" Toyo Open Country A/T and I love 'em. Haven't tried any other kinds yet, since I've only had the truck for less than a year, but still recommend the ones I've got.
Forum: Members Builds 06-10-2014, 04:37 PM
Replies: 299
Views: 58,399
Posted By scanjet4300
Truck looks badass. Props to you for doing such a...

Truck looks badass. Props to you for doing such a good job on it.
Forum: Off-Road Section 06-09-2014, 09:54 PM
Replies: 2,584
Views: 922,671
Posted By scanjet4300
Here's one of the aftermaths 323843 And here's...

Here's one of the aftermaths 323843
And here's one of another time afterwards 323844

Both times the truck was bone stock with h/t tires, but I didn't get stuck once.
Forum: Maintenance Shop 05-25-2014, 11:33 AM
Replies: 5
Views: 672
Posted By scanjet4300
yeah my 4hi works fine but my 4low won't engage,...

yeah my 4hi works fine but my 4low won't engage, and my traction control light comes on. but if i give it the gas it'll take off when it tries to shift up. i think it's a problem with the actuator
Showing results 1 to 6 of 6

 
Forum Jump

All times are GMT -4. The time now is 06:45 PM.


Copyright 2006 - 2017 F150Forum.com