Radio not working, not the fuse - Ford F150 Forum - Community of Ford Truck Fans

Topic Sponsor
Electrical, Lights and Audio "How-To" articles pertaining to the Electrical System (including Lights and Audio) of an F150

Radio not working, not the fuse

Old 06-09-2013, 07:22 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Mar 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Radio not working, not the fuse

Hello! I was hoping to get some advice on fixing my radio. I bought my 89 F150 about 3 months ago. It has an after market radio that worked at the time of purchase, but with no sound. I thought that it could be the speakers, but now the radio won't work at all. I don't think it's a fuse issue because the same fuse powers the headlights and they still work. If there is anyone that can assist, I would appreciate it. I am trying to get the radio and speakers to work as soon as possible. Thank you for the help in advance!
ajwhite78 is offline  
Old 07-03-2013, 08:39 AM
  #2  
Junior Member
 
Join Date: Jul 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had a similar issue with my 94 with the stock head unit. I swapped it out for a pioneer and still no power so i tested it by wiring up the red and yellow together and used the ground and put it to a 12 volt cigarrette adapter. Worked fine so im assuming its in the harness. Someone also told me there is some kind of wire under the hood to eliminate radio interference from the ignition but i havent looked into it much
351w4x4 is offline  
Old 11-06-2018, 10:13 PM
  #3  
Junior Member
 
Join Date: Nov 2018
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi there. Did you find a solution? I recently purchased a 1990 F150 Custom.The after-market radio that came with it when I purchased the truck was working fine. All of a sudden it was not working. I bought a new radio and redid the wiring harness, removing all the shoddy electrical tape and old crimp connectors. When I plugged it in - nothing.

Also, the overhead lamp in the cab stopped working at the same time, as well.

Of course I've checked fuses in the interior fuse box (I've read there may also be an exterior fuse box, but I can't find one in the engine compartment), and all are in order.

Appreciate any help you an offer. Thanks!
gschott is offline  


Thread Tools
Search this Thread
Quick Reply: Radio not working, not the fuse


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: