Topic Sponsor
Electrical, Lights and Audio "How-To" articles pertaining to the Electrical System (including Lights and Audio) of an F150

MLPS or neutral safety switch on 94 Ford F-150 4.9 E40D

 
Old 05-08-2019, 07:44 PM
  #1  
Junior Member
Thread Starter
 
Join Date: May 2019
Posts: 3
Received 0 Likes on 0 Posts
Default MLPS or neutral safety switch on 94 Ford F-150 4.9 E40D

Hi this is my first post so if Iím not doing it correctly please let me know. I have a 94 Ford F-150 2 wheel drive. I put a remanufactured E40D in it and while I was at it I replaced the neutral safety switch. It came with a new connector and I had to move the pins from the old connector. The truck starts but it acts like it doesnít know what gear itís in I am at my wits end I have put 6000 dollars in this truck and I canít even get out of my driveway any help would be appreciated?
Bcrabtree is offline  
Old 05-08-2019, 08:34 PM
  #2  
Fleet Technician
 
RLXXI's Avatar
 
Join Date: Feb 2013
Location: Big Easy
Posts: 23,399
Received 4,804 Likes on 3,730 Posts
Default

Did you align the marks on the switch housing with the center shaft hole markings while the truck is in neutral before bolting it down? They make a special tool for it but it's not needed so long as those marks are aligned.
.
RLXXI is online now  
The following users liked this post:
Bcrabtree (05-08-2019)
Old 05-08-2019, 09:20 PM
  #3  
Junior Member
Thread Starter
 
Join Date: May 2019
Posts: 3
Received 0 Likes on 0 Posts
Default Alignment mark

Thanks for responding so quickly. Yes I put the transmission in neutral then lined up the two fine lines and tightened down the two small bolts on the side but Iím not sure if the the wiring in the new mlp is right the new connector looks nothing like the old one and it came with no instructions. Wired it just like the old connector and the truck cranks but when I put it in gear it hardly moves I checked the fluid and itís good I canít find a diagram for the sensor I bought so Iím running out Of ideas
Bcrabtree is offline  
Old 05-09-2019, 08:22 PM
  #4  
Fleet Technician
 
RLXXI's Avatar
 
Join Date: Feb 2013
Location: Big Easy
Posts: 23,399
Received 4,804 Likes on 3,730 Posts
Default

Originally Posted by Bcrabtree View Post
Thanks for responding so quickly. Yes I put the transmission in neutral then lined up the two fine lines and tightened down the two small bolts on the side but Iím not sure if the the wiring in the new mlp is right the new connector looks nothing like the old one and it came with no instructions. Wired it just like the old connector and the truck cranks but when I put it in gear it hardly moves I checked the fluid and itís good I canít find a diagram for the sensor I bought so Iím running out Of ideas
Wish I could help more, I've done that exact repair many times but that was over 15 years ago when I was working at Ford. The kit's we used had an instruction sheet included that told us where to place the wires.
.
RLXXI is online now  
Old 05-10-2019, 07:13 AM
  #5  
Junior Member
Thread Starter
 
Join Date: May 2019
Posts: 3
Received 0 Likes on 0 Posts
Default Wrong wiring

The switch manufacturer sent me a wiring diagram and I had the wiring wrong sheís back up and running again thanks for all your help.
Bcrabtree is offline  
 


Thread Tools
Search this Thread
Quick Reply: MLPS or neutral safety switch on 94 Ford F-150 4.9 E40D


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: