Topic Sponsor
Engine & Drivetrain "How-To" articles pertaining to the Engine and Drivetrain of an F150 (including Exhaust)

A/C Issue here - Compressor turning but not getting cold..

 
Old 07-09-2018, 09:56 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Jul 2018
Location: Nashville TN
Posts: 7
Likes: 0
Liked 0 Times in 0 Posts
Default A/C Issue here - Compressor turning but not getting cold..

Okay so, in my 1993 F150 5.0, the air conditioning wasn't working when I got it from a family member. I noticed when I turned it to max AC, just hot air would blow. The compressor wasn't turning. It turned out there was no R134 in the system. I charged the system with EZ Freeze. The compressor now turns on and off with the AC switch. The problem is, it is still blowing hot air. I'm going to get a set of gauges tomorrow and see if I can measure some pressures. Let me know if you have any ideas or things I should look for. I didn't notice any of the hoses or pipes getting cold anywhere. At some point that unit was converted over from R12. I have one of the Hayes manuals and looked through their as much as I could. Thanks for any help.
carl1000 is offline  
Old 07-09-2018, 09:58 PM
  #2  
Senior Member
 
digitaltrucker's Avatar
 
Join Date: Dec 2011
Location: Texas
Posts: 7,359
Liked 877 Times in 728 Posts
Default

You should have evacuated it and checked for a leak. Most likely has air in it and moisture, if it has a leak.
digitaltrucker is offline  
Old 07-09-2018, 10:00 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Jul 2018
Location: Nashville TN
Posts: 7
Likes: 0
Liked 0 Times in 0 Posts
Default

I had pressed the pin in the Low side and nothing came out. I assumed it was empty. But I guess that doesn't check for moisture....
carl1000 is offline  
Old 07-09-2018, 10:06 PM
  #4  
Senior Member
 
digitaltrucker's Avatar
 
Join Date: Dec 2011
Location: Texas
Posts: 7,359
Liked 877 Times in 728 Posts
Default

It has to be vacuumed down to charge. In doing that, it pulls out moisture and air. You just cannot charge an empty system.
digitaltrucker is offline  

Thread Tools
Search this Thread
Quick Reply: A/C Issue here - Compressor turning but not getting cold..


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: