92 F150 5.0 Wont Start (tries to fire a couple times) - Page 2 - Ford F150 Forum - Community of Ford Truck Fans

Go Back  Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > Engine Talk > 8 Cylinder Engines
92 F150 5.0 Wont Start (tries to fire a couple times) >

92 F150 5.0 Wont Start (tries to fire a couple times)

Topic Sponsor

92 F150 5.0 Wont Start (tries to fire a couple times)

Old 10-03-2018, 11:44 AM
  #11  
Junior Member
Thread Starter
 
Join Date: Sep 2018
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok, so just to be clear this needs to be plugs up to the power steering pump? I know it's not going to fix my problem or anything but it's supposed to be plugged up to the power steering pump.
MasTwiL is offline  
Old 10-03-2018, 10:09 PM
  #12  
Bronco Guru
 
Steve83's Avatar
 
Join Date: Jan 2018
Location: Memphis, TN, Earth, Milky Way
Posts: 2,611
Thanked 310 Times in 288 Posts
Default

No, your engine doesn't need it. That's why it's not plugged in - there is no PSP on that truck.
Steve83 is offline  
Old 10-08-2018, 01:53 PM
  #13  
Junior Member
Thread Starter
 
Join Date: Sep 2018
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

So, went ahead and rented a fuel pressure test kit. Got a fuel filter and changed it out too. 32lbs at idle and 38 when revving so I believe that's ok? Still idling rough and not revving very high. I did have to spray some carb cleaner in the intake again to get it started but only seem to have to do that when it's been sitting for a while. Still working on the vacuum lines.

*** I did want to add/ask..... It did all this once before while at the same time my shifter cable broke... I did not thing these two issues could be related but had to replace the shifter cable regardless so I did that and to my surprise... it ran fine after. then a week later it crapped out again. I know there's some sort of a sensor that tells it it's in park in order to start up but is there anything else coming from the transmission that would affect the engine like this? I've disconnected the shifter from the transmission and put in park manually just to see but no improvement.
MasTwiL is offline  
Old 10-08-2018, 03:56 PM
  #14  
Bronco Guru
 
Steve83's Avatar
 
Join Date: Jan 2018
Location: Memphis, TN, Earth, Milky Way
Posts: 2,611
Thanked 310 Times in 288 Posts
Default

No, the transmission can be completely unplugged, and the engine will still run normally.


(phone app link)


The MLPS is involved in the cranking circuit, but not the fuel pump or engine management.


(phone app link)
Steve83 is offline  


Thread Tools
Search this Thread
Quick Reply: 92 F150 5.0 Wont Start (tries to fire a couple times)


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: