Topic Sponsor
Members Builds See any build threads created by members to track progress of their projects.
Sponsored by:
Sponsored by:

2016 Platinum FX4 Magnetic Gray

 
Old 01-16-2019, 10:58 AM
  #251  
Flaccid Member
Thread Starter
 
DeltaNu1142's Avatar
 
Join Date: Sep 2016
Location: Tampa, FL
Posts: 1,660
Liked 318 Times in 213 Posts
Default

1/16/2019
30,262 miles

I put washer fluid in the reservoir for the first time since I purchased the truck. I added about 3 quarts of Rain-X fluid, and the reservoir wasnít empty when I started, so Iím not sure what the capacity is.
DeltaNu1142 is online now  
Old 01-30-2019, 12:12 AM
  #252  
Member
 
Join Date: Dec 2018
Location: SC
Posts: 33
Likes: 0
Liked 2 Times in 2 Posts
Default

Originally Posted by DeltaNu1142 View Post
7/8/2017
10,xxx miles

I replaced the keypad in the driver side door trim. I thought all this time that the clip was broken; in fact, it was just missing a small metal piece that had fallen into the door when I last pulled it out. It was a huge pain to remove & replace.

I also found a small spot of surface rust on the new bumper. I sanded it down, cleaned it, and sprayed it with satin black paint.

I took inventory of the parts I need to install my grille. I'm missing only one black plastic stud retainer, and thanks to @Firerunner, I should have it soon. Here's a preview:



Satin black mesh and trim; the rest is Magnetic Metallic.
did u clearcoat this or just paint? And how's it holding up?
v6procharged is online now  
Old 01-30-2019, 03:41 AM
  #253  
Flaccid Member
Thread Starter
 
DeltaNu1142's Avatar
 
Join Date: Sep 2016
Location: Tampa, FL
Posts: 1,660
Liked 318 Times in 213 Posts
Default

Originally Posted by v6procharged View Post
did u clearcoat this or just paint? And how's it holding up?
The shop painted and cleared it. It's holding up as well as the rest of the factory paint.
DeltaNu1142 is online now  
Old 01-30-2019, 02:53 PM
  #254  
Member
 
Join Date: Dec 2018
Location: SC
Posts: 33
Likes: 0
Liked 2 Times in 2 Posts
Default

Originally Posted by DeltaNu1142 View Post

The shop painted and cleared it. It's holding up as well as the rest of the factory paint.
word. Just doesn't look as shiny as rest of truck
v6procharged is online now  
Old 02-06-2019, 08:56 AM
  #255  
Flaccid Member
Thread Starter
 
DeltaNu1142's Avatar
 
Join Date: Sep 2016
Location: Tampa, FL
Posts: 1,660
Liked 318 Times in 213 Posts
Default

2/6/2019
31,334 miles

Small stuff today. Inspired by some posts in the <$50 mods thread, I grabbed a drawer handle for my console organizer. Home Depot didn’t have the black plastic ones, so I had to spring for the $3.07 brushed stainless handle. I just drilled some holes and used some #8-32 x 3/8” machine screws to fasten it on.




The screws that came with the handle were way too long to use with the organizer, but they just happened to be the exact size I needed for my trailer connector. I’ve been meaning to get that fastened right since I installed the rear bumper. It’s still not right; I need a magical 11/32” deep socket with paper-thin walls to get it tightened down. Fab Fours really didn’t think that one through.

DeltaNu1142 is online now  
Old 02-08-2019, 11:17 AM
  #256  
Flaccid Member
Thread Starter
 
DeltaNu1142's Avatar
 
Join Date: Sep 2016
Location: Tampa, FL
Posts: 1,660
Liked 318 Times in 213 Posts
Default

2/7/2019
31,369 miles

My engine developed a tick, on every revolution, at operating temps. I reloaded the stock tune and it went away. I reached out to OZ Tuning via email, and Ken got back to me right away. He highlighted the recent TSB # 7718, about the “typewriter tick,” and it made me feel a little better. I still don’t like the noise, but I went ahead and reloaded the tune today, 2/8/2019, with 31,406 miles.

Last edited by DeltaNu1142; 02-08-2019 at 12:05 PM.
DeltaNu1142 is online now  
Old Yesterday, 10:23 AM
  #257  
Flaccid Member
Thread Starter
 
DeltaNu1142's Avatar
 
Join Date: Sep 2016
Location: Tampa, FL
Posts: 1,660
Liked 318 Times in 213 Posts
Default

4/17/2019
33,189 miles

I have cut my commute by at least 30 miles per day, so I'm using way less gas and adding on way fewer miles. The engine tick has not returned. I replaced my engine air filter today. Shown below is the old one coming out and the new one going in.



I have a cabin filter ready to go in. I've mainly been waiting for the pollen to subside before changing filters. I've also got Mobil 1 5W-20 and a Motorcraft oil filter ready, but the oil indicator shows 8% life left and with my short drive to work it could be awhile. I'm due for a tire rotation. Hopefully this weekend I'll get to do that, along with lubricating and checking torque on front & rear suspension components.
DeltaNu1142 is online now  
 


Thread Tools
Search this Thread
Quick Reply: 2016 Platinum FX4 Magnetic Gray


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: