New iac and TPS didn't help - Ford F150 Forum - Community of Ford Truck Fans

Topic Sponsor
1997 - 2003 Ford F150 General discussion on the Ford 1997 - 2003 F150 truck.

New iac and TPS didn't help

Old 10-10-2018, 02:04 PM
  #1  
Senior Member
Thread Starter
 
Join Date: Jul 2018
Posts: 253
Thanks: 0
Thanked 0 Times in 0 Posts
Default New iac and TPS didn't help

Got the motorcraft IAC and TPS in today and still having rough idle when stopping, idles fine when cold, when it warms up runs horribly
10thGenFnatic is offline  
Old 10-10-2018, 02:10 PM
  #2  
Senior Member
 
fordguy2100's Avatar
 
Join Date: Apr 2014
Location: Indiana
Posts: 4,746
Thanked 250 Times in 218 Posts
Default

Originally Posted by 10thGenFnatic
Got the motorcraft IAC and TPS in today and still having rough idle when stopping, idles fine when cold, when it warms up runs horribly
Stop starting new threads you ignorant waste of time. You make people chase your problems across different usernames and threads. STICK TO ONE THREAD.
fordguy2100 is offline  
Old 10-10-2018, 02:11 PM
  #3  
Senior Member
Thread Starter
 
Join Date: Jul 2018
Posts: 253
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by fordguy2100 View Post
Stop starting new threads you ignorant waste of time. You make people chase your problems across different usernames and threads. STICK TO ONE THREAD.
the thread got closed dumb ****
10thGenFnatic is offline  
Old 10-10-2018, 02:14 PM
  #4  
Senior Member
 
fordguy2100's Avatar
 
Join Date: Apr 2014
Location: Indiana
Posts: 4,746
Thanked 250 Times in 218 Posts
Default

Originally Posted by 10thGenFnatic
the thread got closed dumb ****
Gee all of your threads across all your usernames are closed? ALL of them? Cause they are all the same crap. Do yourself and every here a favor and follow through on at least one thing... go sell your truck
fordguy2100 is offline  
Old 10-10-2018, 02:15 PM
  #5  
Senior Member
Thread Starter
 
Join Date: Jul 2018
Posts: 253
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by fordguy2100 View Post
Gee all of your threads across all your usernames are closed? ALL of them? Cause they are all the same crap. Do yourself and every here a favor and follow through on at least one thing... go sell your truck
okay so i only have 2, just help me fix this damn truck
10thGenFnatic is offline  
Old 10-10-2018, 02:21 PM
  #6  
97 F150 XLT
 
white89gt's Avatar
 
Join Date: Dec 2015
Posts: 8,045
Thanked 559 Times in 531 Posts
Default

Watch and learn.

white89gt is offline  
Old 10-10-2018, 03:01 PM
  #7  
Senior Member
Thread Starter
 
Join Date: Jul 2018
Posts: 253
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by white89gt View Post
thank you, I've cleaned the TB do i need to take off the intake and clean it too?
10thGenFnatic is offline  
Old 10-10-2018, 03:40 PM
  #8  
Living by the OBD Code
 
Join Date: Nov 2017
Location: Oregon
Posts: 1,011
Thanked 120 Times in 113 Posts
Default

Originally Posted by 10thGenFnatic View Post
Got the motorcraft IAC and TPS in today and still having rough idle when stopping, idles fine when cold, when it warms up runs horribly
Pretend that this really is a new problem and this is your first post about it. Do you think that there is enough detail here for anybody to know what you're talking about? Not even clear which engine you're working on.

The more detail the better.
BareBonesXL is offline  
Old 10-10-2018, 03:56 PM
  #9  
Senior Member
Thread Starter
 
Join Date: Jul 2018
Posts: 253
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by BareBonesXL View Post
Pretend that this really is a new problem and this is your first post about it. Do you think that there is enough detail here for anybody to know what you're talking about? Not even clear which engine you're working on.

The more detail the better.
the people i trust to help me know the issue and the motor, 97 f150 4.6 4x4,when in gear, any gear drive or reverse, the idle is like 500 or 450, and when i come to a stop it almost stalls
10thGenFnatic is offline  
Old 10-10-2018, 03:59 PM
  #10  
Living by the OBD Code
 
Join Date: Nov 2017
Location: Oregon
Posts: 1,011
Thanked 120 Times in 113 Posts
Default

Originally Posted by 10thGenFnatic View Post
the people i trust to help me know the issue and the motor,
Good luck then.
BareBonesXL is offline  

Thread Tools
Search this Thread
Quick Reply: New iac and TPS didn't help


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: