Topic Sponsor
1997 - 2003 Ford F150 General discussion on the Ford 1997 - 2003 F150 truck.

97 F-150 XL V6 4.2L Cruise control not working

 
Old 03-12-2019, 10:55 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Mar 2019
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default 97 F-150 XL V6 4.2L Cruise control not working

It has a standard transmission, vacuum cruise control with no place or plug for brake release switch, no power windows/locks. I checked the vacuum lines and sealed them off, checked the fuses, and yet I still have no cruise. No indicator light shows when attempting to operate, and I have yet to find a replacement lever switch anywhere for it. Not sure if it is the switch or not.
LHurraw is offline  
Old 03-13-2019, 09:24 AM
  #2  
Senior Member
 
Join Date: Oct 2018
Location: Maysville KY
Posts: 1,499
Received 104 Likes on 100 Posts
Default

check and see if the emergency brake is engaged
DarrinT04 is offline  
Old 03-13-2019, 09:25 AM
  #3  
ford dealer parts guy
iTrader: (1)
 
djfllmn's Avatar
 
Join Date: Jun 2012
Posts: 14,478
Received 982 Likes on 812 Posts
Default

Originally Posted by LHurraw View Post
It has a standard transmission, vacuum cruise control with no place or plug for brake release switch, no power windows/locks. I checked the vacuum lines and sealed them off, checked the fuses, and yet I still have no cruise. No indicator light shows when attempting to operate, and I have yet to find a replacement lever switch anywhere for it. Not sure if it is the switch or not.
sounds like an aftermarket system to me. Can you post a picture of the controls?
djfllmn is offline  
Old 03-13-2019, 09:28 AM
  #4  
Senior Member
 
Join Date: Oct 2018
Location: Maysville KY
Posts: 1,499
Received 104 Likes on 100 Posts
Default

i didn't think the XL's had factory cruise control in these years
DarrinT04 is offline  
Old 03-17-2019, 02:17 PM
  #5  
Junior Member
 
snowway's Avatar
 
Join Date: Feb 2019
Posts: 23
Received 1 Like on 1 Post
Default

If I am correct, the "Cruise" light wasn't added until late 99-00. My early 99 has no cruise light. Some models had the cruise cut-off on the bottom of the master cylinder, try there. As a quick check list: Does the horn work? Do your reverse lights work? Have you visually inspected the Clutch Position Sensor?
snowway is offline  
Old 03-17-2019, 03:06 PM
  #6  
Senior Member
 
Join Date: Nov 2006
Location: MI
Posts: 17,195
Received 1,238 Likes on 1,167 Posts
Default

Originally Posted by LHurraw View Post
It has a standard transmission, vacuum cruise control with no place or plug for brake release switch, no power windows/locks. I checked the vacuum lines and sealed them off, checked the fuses, and yet I still have no cruise. No indicator light shows when attempting to operate, and I have yet to find a replacement lever switch anywhere for it. Not sure if it is the switch or not.
Your referring to the cruise deactivation switch at MC ( the front of it). Not sure what you mean by lever switch. If your vehicle has the correct master cylinder (it could of been changed in the past with one without cruise, by mistake), then it should be in plain site with fused recall harness connected. Your model was in the Ford recall group. So make sure you check the harness itself as it has a small in-line fuse you can't see. It's taped up in the harness. If you have the correct master, you can simply test the recall harness/fuse and cruise activation by removing the recall harness completely. Set it aside for now, then just connect directly to the masters deactivation switch instead. This is the way it came from the factory, it will connect direct. This is just to check the recall harness integrity, takes couple minutes to switch out. Take the truck for a ride, check cruise activation and deactivation. If it works, unwrap the tape from the recall harness, replace inline fuse. Just don't run it without the recall harness permanently. The truck can literally burn to the ground and take your garage and house with it...reason it was recalled.

But yea, make sure you have the correct master/parts first. Otherwise, you don't have cruise....yet.

Originally Posted by DarrinT04 View Post
i didn't think the XL's had factory cruise control in these years
That might be correct, but they are wired for it. The OP must have the correct steering wheel. He would need the right master cylinder. The only other reason it wouldn't work is if it wasn't programed for cruise....doubt that's the case.

Originally Posted by snowway View Post
If I am correct, the "Cruise" light wasn't added until late 99-00. My early 99 has no cruise light. Some models had the cruise cut-off on the bottom of the master cylinder, try there. As a quick check list: Does the horn work? Do your reverse lights work? Have you visually inspected the Clutch Position Sensor?
I've never seen the cruise light in the gen 10 150's. The Navigators had them from the get go.

Yea, that's correct, deactivation switch is on the master. I'm not sure how the CPS integrates....seems like it would have to though. Not sure about that.

Last edited by Jbrew; 03-17-2019 at 03:10 PM.
Jbrew is online now  
Old 03-20-2019, 04:13 PM
  #7  
Junior Member
Thread Starter
 
Join Date: Mar 2019
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default

There is already a cruise control unit on the truck that is not operational. I have recently installed a servo as there were connections to install one, and I am going to replace the MC as well in hopes that this will give me CC again. Also, as to where I said lever switch, there are no buttons on the steering wheel, but instead a lever where the tilt would be.
LHurraw is offline  
Old 03-20-2019, 10:23 PM
  #8  
Junior Member
Thread Starter
 
Join Date: Mar 2019
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default Update

Installed new master cylinder, brake release switch, and cruise servo with the cable. Still no cruise control. Does anyone know if I need to rewire the switch in the cab to the servo?

pictures show new cc unit and old cc unit.

Old unit

Throttle with new unit

Complete setup

Complete setup

Old in comparison to new
LHurraw is offline  
Old 03-20-2019, 11:30 PM
  #9  
Senior Member
 
akdoggie's Avatar
 
Join Date: Jul 2010
Location: Anchorage, Alaska
Posts: 6,121
Received 609 Likes on 576 Posts
Default

Everyone is forgetting the brake switch on the pedal. The wires break there or the brake light switch might be the culprit
akdoggie is offline  
Old 03-20-2019, 11:37 PM
  #10  
Junior Member
Thread Starter
 
Join Date: Mar 2019
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default

I have no issues with my brake or reverse lights whatsoever
LHurraw is offline  

Thread Tools
Search this Thread
Quick Reply: 97 F-150 XL V6 4.2L Cruise control not working


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: