Topic Sponsor
1997 - 2003 Ford F150 General discussion on the Ford 1997 - 2003 F150 truck.

4.6 rattle & knocking

 
Old 02-01-2019, 07:56 PM
  #11  
Junior Member
Thread Starter
 
lonestarjeff's Avatar
 
Join Date: Apr 2013
Posts: 28
Received 0 Likes on 0 Posts
Default

The new COP's won't arrive until monday, but I decided to do a throttle body service while the air pipe is pulled off. I only recall having it cleaned once since I bought the truck new

It was pretty filthy inside & out. I was intending to just clean the TB, but when I saw black tar growing inside the horn out of each EGR port I decided to pull everything off & work it over. I had to use a drill to get started cleaning out those ports. I can't believe the EGR worked at all.



Sorry, I forgot to snap a pic of the TB before cleaning it, but it cleaned up nicely....



Now I need to do the same service to my Expedition. I've never cleaned the TB in the 120k miles I've had it.
lonestarjeff is offline  
Old 02-01-2019, 08:19 PM
  #12  
Senior Member
 
Join Date: Nov 2006
Location: MI
Posts: 17,194
Received 1,238 Likes on 1,167 Posts
Default

...

Last edited by Jbrew; 02-07-2019 at 12:03 PM.
Jbrew is offline  
Old 02-01-2019, 10:25 PM
  #13  
Senior Member
 
Join Date: Nov 2006
Location: MI
Posts: 17,194
Received 1,238 Likes on 1,167 Posts
Default

...

Last edited by Jbrew; 02-07-2019 at 12:03 PM.
Jbrew is offline  
Old 02-02-2019, 09:50 AM
  #14  
Junior Member
Thread Starter
 
lonestarjeff's Avatar
 
Join Date: Apr 2013
Posts: 28
Received 0 Likes on 0 Posts
Default

Originally Posted by Jbrew View Post
This sounds like an EGR problem.....What you can do, well, the quickest way to confirm is totally block the EGR port. Slide a piece of metal between the EGR and intake.....
I'm not following the logic, the ports were already completely blocked before I cleaned the TB. You're thinking the EGR may have been stuck open?
lonestarjeff is offline  
Old 02-02-2019, 09:53 AM
  #15  
ford dealer parts guy
iTrader: (1)
 
djfllmn's Avatar
 
Join Date: Jun 2012
Posts: 14,476
Received 982 Likes on 812 Posts
Default

Originally Posted by lonestarjeff View Post
I'm not following the logic, the ports were already completely blocked before I cleaned the TB. You're thinking the EGR may have been stuck open?
its possible. I had a 97 saturn that would throw an EGR code occasionally. eventually it got to the point that the car starting running bad. I actually found a little piece of carbon stuck between the valve itself and the housing. That will cause all kinds of fits
djfllmn is online now  
Old 02-02-2019, 10:38 AM
  #16  
Senior Member
 
Join Date: Nov 2006
Location: MI
Posts: 17,194
Received 1,238 Likes on 1,167 Posts
Default

Originally Posted by lonestarjeff View Post
I'm not following the logic, the ports were already completely blocked before I cleaned the TB. You're thinking the EGR may have been stuck open?
Then don't do it
Jbrew is offline  
Old 02-02-2019, 11:15 AM
  #17  
Senior Member
 
Join Date: Nov 2006
Location: MI
Posts: 17,194
Received 1,238 Likes on 1,167 Posts
Default

...

Last edited by Jbrew; 02-07-2019 at 12:04 PM.
Jbrew is offline  
Old 02-06-2019, 07:58 PM
  #18  
Junior Member
Thread Starter
 
lonestarjeff's Avatar
 
Join Date: Apr 2013
Posts: 28
Received 0 Likes on 0 Posts
Default

Put in the new set of Denso COPs yesterday, but no effect on the knocking. As suggested above I took another look at the EGR, cleaned it up, made sure it would move, & re-installed....no effect. So, also as suggested above, I snipped a piece of aluminum & blocked it between the valve & intake.....definitely diminished the knocking. It still sometimes clatters from 1k-1.5k rpm & almost always pulling away from a stop, but shorter duration.

Definitely getting vacuum to the top of the valve, so the diaphragm must have a crack or hole. No codes & the evap system test always fails on my OBD scanner.
lonestarjeff is offline  
Old 02-06-2019, 10:50 PM
  #19  
Senior Member
 
Join Date: Nov 2006
Location: MI
Posts: 17,194
Received 1,238 Likes on 1,167 Posts
Default

...

Last edited by Jbrew; 02-07-2019 at 12:13 PM. Reason: No response, waste of time regardless. Cleaned it up.
Jbrew is offline  
Old 02-08-2019, 04:42 PM
  #20  
Junior Member
Thread Starter
 
lonestarjeff's Avatar
 
Join Date: Apr 2013
Posts: 28
Received 0 Likes on 0 Posts
Default

I pulled the green vac line off the EGR & drove the truck today. It had the same effect as blocking the EGR with a piece of metal....still knocking but not as bad. I take back my comment earlier about there being a vacuum present in the green line at idle, when I checked it today it was faint but pulsing. Hope that makes sense.

I also read the Scorpio EGR link which was helpful understanding the system. Sorry for taking so long to get back.
lonestarjeff is offline  

Thread Tools
Search this Thread
Quick Reply: 4.6 rattle & knocking


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: