This is that retrofit thread we talked about! - Page 170 - Ford F150 Forum - Community of Ford Truck Fans

Go Back  Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2009 - 2014 Ford F150
This is that retrofit thread we talked about! >

This is that retrofit thread we talked about!

Topic Sponsor
2009 - 2014 Ford F150 General discussion on 2009 - 2014 Ford F150 truck.

This is that retrofit thread we talked about!

Reply

 
 
 
Old 07-25-2017, 09:13 PM
  #1691  
Senior Member
 
06F150CFCT's Avatar
 
Join Date: Mar 2011
Location: Cranston, RI
Posts: 3,317
Thanked 119 Times in 116 Posts
Default

Originally Posted by doc1988
I'm going through this right now. I only have 1 80m LED switchback halo per shroud and I wired the amber wire to the turn signal and the white wire to the +12vDC wire on the trucks main headlight harness w/ the ground to the fender screw. BUT.... they aren't working like they should. Can't get them to turn white, passenger side stays full amber and won't blink, driver side (from what it sounds needs the BCM reset) because the halo doesn't even light up and the blinker isn't working now. So if I understand this right I need to disconnect the halo wires? then reset the BCM? and then before connecting them again get a relay harness??? I have a 2012 F150.
I have the panamera switchback shrouds and I wired the shrouds to the running light harness/plug. I used the turn signal wire, the running light wire and wired the ground to the last wire (ground wire) on the connector. Everything worked perfectly. Not sure why yours isn't working.
06F150CFCT is offline  
Reply With Quote
Old 07-25-2017, 09:26 PM
  #1692  
2012screw fx4 4" RCXw35's
 
Join Date: May 2016
Location: Kansas
Posts: 15
Thanked 0 Times in 0 Posts
Default



The white wire for the halo is wired into the trucks main running lights wire harness and the amber is wired into the turn signals wiring harness.
doc1988 is offline  
Reply With Quote
Old 07-25-2017, 09:27 PM
  #1693  
2012screw fx4 4" RCXw35's
 
Join Date: May 2016
Location: Kansas
Posts: 15
Thanked 0 Times in 0 Posts
Default

did it work for both the passenger and driver side that way?
doc1988 is offline  
Reply With Quote
Old 07-25-2017, 09:31 PM
  #1694  
Senior Member
 
M3TOSVT's Avatar
 
Join Date: May 2016
Posts: 331
Thanked 32 Times in 29 Posts
Default

Originally Posted by doc1988 View Post
did it work for both the passenger and driver side that way?
Are you attached to the right wire?

M3TOSVT is offline  
Reply With Quote
Old 07-25-2017, 09:39 PM
  #1695  
2012screw fx4 4" RCXw35's
 
Join Date: May 2016
Location: Kansas
Posts: 15
Thanked 0 Times in 0 Posts
Default

I'm fairly certain I have them on the right wires but I went off of what a multimeter read back to me (I have some colorblindness so I try not to depend too much on the colors) they are on the ones that read the closest to 12vDC. honestly I'm not sure about the diagram. I honestly don't know how to read that LOL.
doc1988 is offline  
Reply With Quote
Old 07-25-2017, 09:44 PM
  #1696  
Senior Member
 
M3TOSVT's Avatar
 
Join Date: May 2016
Posts: 331
Thanked 32 Times in 29 Posts
Default

Originally Posted by doc1988 View Post
I'm fairly certain I have them on the right wires but I went off of what a multimeter read back to me (I have some colorblindness so I try not to depend too much on the colors) they are on the ones that read the closest to 12vDC. honestly I'm not sure about the diagram. I honestly don't know how to read that LOL.
The amber should come off the Blue and Green wire. The one that alternates 12vdc. Im just finding it weird that it is always amber now.
M3TOSVT is offline  
Reply With Quote
Old 07-25-2017, 09:49 PM
  #1697  
2012screw fx4 4" RCXw35's
 
Join Date: May 2016
Location: Kansas
Posts: 15
Thanked 0 Times in 0 Posts
Default

thats the solid green w/blue strip right? there were 2 green with strips next to each other so it was hard to tell the colors of the strips. But going off of the pic i believe it was the middle wire out of the 3 for the turning signal.
doc1988 is offline  
Reply With Quote
Old 07-25-2017, 09:53 PM
  #1698  
2012screw fx4 4" RCXw35's
 
Join Date: May 2016
Location: Kansas
Posts: 15
Thanked 0 Times in 0 Posts
Default

so i downloaded the FORScan app to my computer, and I'm thinking about the adaptor, I have a SCT X4 tuner and was wondering if i could use that and connect it to my computer through the USB port, is that the same place I go to look at the error codes?
doc1988 is offline  
Reply With Quote
Old 07-25-2017, 10:33 PM
  #1699  
Senior Member
 
M3TOSVT's Avatar
 
Join Date: May 2016
Posts: 331
Thanked 32 Times in 29 Posts
Default

Originally Posted by doc1988 View Post
so i downloaded the FORScan app to my computer, and I'm thinking about the adaptor, I have a SCT X4 tuner and was wondering if i could use that and connect it to my computer through the USB port, is that the same place I go to look at the error codes?
No. You will need the ELM 327 adapter to read the various modules throughout the truck. The SCT will just read the OBD II check engine light codes and a couple other things.
M3TOSVT is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread
Quick Reply: This is that retrofit thread we talked about!


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: