Ford F150 Forum - Community of Ford Truck Fans

Ford F150 Forum - Community of Ford Truck Fans (https://www.f150forum.com/)
-   2009 - 2014 Ford F150 (https://www.f150forum.com/f38/)
-   -   Poll: New CAC results (limited to 2 part numbers) (https://www.f150forum.com/f38/poll-new-cac-results-limited-2-part-numbers-193107/)

bchandler02 02-02-2013 09:07 PM

Poll: New CAC results (limited to 2 part numbers)
 
For a history of why this is created, please see this thread.

We have determined in that thread that the new part numbers are as follows:
Factory 2013: DL34-9L440-AC
Trucks with TSB 12-10-19 applied: BL3Z-6K775-B

Please only vote in this poll if you have 1 of these two part numbers for your CAC, and have driven in conditions that would typically cause the condensation problems.

Do you still experience the loss of power when accelerating in high humidity/rain after a period of constant speed driving?

If you do, comments are welcome.

This is NOT a thread for engine wars.

H-60 Electrician 02-02-2013 10:07 PM

I have DL34-9L440-AC in my 2013 Lariat, 10-25-12 build date, but I have one number thats different from the ones in the post. Instead of fomoco E1, mine is E2. Dont know if that makes a difference, but I have not had any issues with my ECO.

Rockhopper 02-02-2013 11:57 PM

The only concern about the poll I have is the wording. Meaning that some may say they have issues with the engine struggling when maybe it isn't a condensation issue at all. For example a bad coil or improper spark plug gapping. Maybe "Do you still experience the loss of power in high humidity/rainy conditions" type of question. Just want the poll to not be muddied with inaccuracies. I am waiting on a new CAC like many others and really hope that this works out. Good luck.

mrpositraction 02-03-2013 09:33 AM

I said I have had no problems since the fix but I also haven't driven on long trips though the conditions that did it before for me.

pat247 02-03-2013 10:22 AM

My truck had 13k miles on it before it had an issue. Now I wait like many others for the TSB to be completed.

HoustonFordGuy 02-03-2013 05:14 PM

I have been living with 12-10-19B and intercoolerBL3Z*6K775*B at 2.5 months now. That’s just about 2,000 miles on the new intercooler and new left CAT (which has already clogged up again).

The truck has considerably less power.

The MPG’s in the city were 18 before the fix and 14 after the fix. The best I get onthe hiway is 18 now; use to be about 22-24MPGs.

Without reservation I can say this is my last Ford. If Ford were to just “give” me a new 5.0 F150I would not take, because the company is donkey poop.

Now when any one tells me about their great Ford EcoBoost(car or truck), I just laugh.

bchandler02 02-03-2013 11:02 PM

Reminder to follow the thread in my original post here, but we think it has been determined that if your part number starts with B it is one of the problematic ones, and if it starts with D it should be good.

I hope more people can take this poll with a 2013 or a fixed 2012 and we can get a pulse on the problem being truly fixed.

kitzi 02-03-2013 11:08 PM

I voted fixed...Since my 2013 (8/12 build) received TSB 121115A on1/16 I've not had an issue.

bchandler02 02-03-2013 11:12 PM


Originally Posted by kitzi (Post 2397278)
I voted fixed...Since my 2013 (8/12 build) received TSB 121115A on1/16 I've not had an issue.

Have you driven in the rainy/humid conditions that would typically cause the problem?

fooseF150 02-03-2013 11:27 PM

I have a 13 and I was driving on the hwy. I went to pass someone and when I hit the gas I didn't get any response. I barely got around the other person. Is this the problem the rest of you have? Or is it just cuz I'm used to having a V8 with lots of power.


All times are GMT -4. The time now is 08:56 PM.


© 2019 MH Sub I, LLC dba Internet Brands