my new fx4 - Page 2 - Ford F150 Forum - Community of Ford Truck Fans



2009 - 2014 Ford F150 General discussion on 2009 - 2014 Ford F150 truck.
Sponsored by:
Sponsored by:

my new fx4

Reply
 
 
 
Thread Tools Search this Thread
Old 01-28-2014, 08:40 AM   #11
Senior Member
Thread Starter
 
Executioner408's Avatar
 
Join Date: Nov 2012
Posts: 258
Thanked 9 Times in 9 Posts
Default

Quick question I have a screen but my navigation doesn't work what can it be I have the chip for it but cant read the memory chip.
Executioner408 is offline   Reply With Quote
Old 01-28-2014, 08:42 AM   #12
Kickin it
 
Join Date: Sep 2013
Location: Houston, TX
Posts: 2,233
Thanked 157 Times in 144 Posts
Default

Do you have the navigation screen? Or just the standard MFT?
mikeyfitz is offline   Reply With Quote
Old 01-28-2014, 09:14 AM   #13
Custom Member
 
masitile's Avatar
 
Join Date: Dec 2011
Location: North of Boston Ma.
Posts: 4,622
Thanked 557 Times in 464 Posts
Default

Great truck. Never considered red, but I like that color and would drive it with pride.
What's your setup? 4"/8" screen? I have the 8" mft, that says navigation on the top right of the 4 section screen.
My navigation SD card is inside the console.

Last edited by masitile; 01-28-2014 at 07:12 PM.
masitile is offline   Reply With Quote
The Following User Says Thank You to masitile For This Useful Post:
Executioner408 (01-28-2014)
Old 01-28-2014, 09:50 AM   #15
Ford Customer Service
 
FordIVTteam's Avatar
 
Join Date: Jul 2013
Posts: 1,906
Thanked 291 Times in 190 Posts
Default

Quote:
Originally Posted by Executioner408 View Post
Quick question I have a screen but my navigation doesn't work what can it be I have the chip for it but cant read the memory chip.
Hi Executioner408,

Does the top right corner of your screen read INFORMATION or NAVIGATION? If you're seeing the former, most likely your system was not factory-equipped with nav. If you're unsure of this, shoot me your VIN and I can verify what's installed.

Antonio
FordIVTteam is offline   Reply With Quote
Old 01-28-2014, 10:42 AM   #16
Senior Member
Thread Starter
 
Executioner408's Avatar
 
Join Date: Nov 2012
Posts: 258
Thanked 9 Times in 9 Posts
Default

Quote:
Originally Posted by FordIVTteam View Post
Hi Executioner408,

Does the top right corner of your screen read INFORMATION or NAVIGATION? If you're seeing the former, most likely your system was not factory-equipped with nav. If you're unsure of this, shoot me your VIN and I can verify what's installed.

Antonio
Yeah mine says information instead of the navigation I have the 8in screen. I even tried out my buddies chip cause he has the exact same truck except his is a 5.0
Executioner408 is offline   Reply With Quote
Old 01-28-2014, 11:57 AM   #17
Ford Customer Service
 
FordIVTteam's Avatar
 
Join Date: Jul 2013
Posts: 1,906
Thanked 291 Times in 190 Posts
Default

Quote:
Originally Posted by Executioner408 View Post
Yeah mine says information instead of the navigation I have the 8in screen. I even tried out my buddies chip cause he has the exact same truck except his is a 5.0
Executioner408,

A SD nav card won't work with the vehicle unless it is factory-equipped to have navigation. PM your VIN and I can help confirm what the vehicle is actually equipped with.

Antonio
FordIVTteam is offline   Reply With Quote
Old 01-28-2014, 12:54 PM   #18
Senior Member
 
Red89gt's Avatar
 
Join Date: Apr 2013
Location: Athens, OH
Posts: 583
Thanked 56 Times in 55 Posts
Default

Truck looks great, and great color, I did a drive through the ford lot the other day and this color looks awesome in the bright sunlight. If I could justify the $50k truck since I have a paid off good running vehicle I would be driving one in an instant.
Red89gt is offline   Reply With Quote
The Following User Says Thank You to Red89gt For This Useful Post:
Executioner408 (01-28-2014)
Old 01-28-2014, 01:21 PM   #19
Five-0 Ret.
 
Wanted33's Avatar
 
Join Date: Mar 2011
Location: Down South in Dixie
Posts: 5,657
Thanked 661 Times in 567 Posts
Default

Quote:
Originally Posted by Toddman34 View Post
Congrats, love the truck! Just not the color!

Ouch.....the cut was deep.



Unlike my good buddy [MENTION=118343]Toddman34[/MENTION], I love the color. Congrats.
Wanted33 is offline   Reply With Quote
Old 01-28-2014, 01:25 PM   #20
Senior Member
Thread Starter
 
Executioner408's Avatar
 
Join Date: Nov 2012
Posts: 258
Thanked 9 Times in 9 Posts
Default

thanks boss it was either between ruby red or the blue flame but they did not have it so i pulled the trigger on this one
Quote:
Originally Posted by Wanted33 View Post
Ouch.....the cut was deep.



Unlike my good buddy @Toddman34, I love the color. Congrats.
Executioner408 is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Anyone else have a Canadian FX4? Silverlx 2009 - 2014 Ford F150 34 03-22-2017 12:57 PM
Texas: 2012 F150 FX4 Ecoboost - Loaded OptimiStick 2009 - 2014 Truck Sales 5 04-11-2016 02:43 PM
FX4 suspension to soft? perauto1 2015 - Present Ford F150 26 11-01-2015 12:19 PM
International: 2013 F150 FX4 6.2L SuperCab *LOADED* + **Extras** schissler 2009 - 2014 Truck Sales 5 10-05-2015 01:54 PM
Southeast: 2013 FX4 lifted 5.0 SuperCrew *LOADED**EXTRAS** usmcknight69 2009 - 2014 Truck Sales 1 09-26-2015 02:00 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 04:46 AM.


Copyright 2006 - 2017 F150Forum.com
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: