ABS light, Brake light, Check Brake System and anti skid indicators on analog readout - Ford F150 Forum - Community of Ford Truck Fans

Go Back  Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2009 - 2014 Ford F150
ABS light, Brake light, Check Brake System and anti skid indicators on analog readout >

ABS light, Brake light, Check Brake System and anti skid indicators on analog readout

Topic Sponsor
2009 - 2014 Ford F150 General discussion on 2009 - 2014 Ford F150 truck.

ABS light, Brake light, Check Brake System and anti skid indicators on analog readout

Old 09-04-2015, 08:18 AM
  #1  
Junior Member
Thread Starter
 
Join Date: Sep 2015
Posts: 3
Thanked 0 Times in 0 Posts
Unhappy ABS light, Brake light, Check Brake System and anti skid indicators on analog readout

I have a 2010 F150 XLT CC 4.6L 4x4 that has the following indicators:
Brake light on
ABS light on
Check Brake System on dash readout
Anti Skid indicator flashing on dash readout

These all came on when I slammed on my brakes in the snow. Truck slid, truck shut off, started it back up and all lights were on.

Scanner said bad ABS module, spent $750 replacing it myself. No change in lights.

Was not aware it needed to be "flashed" by dealer computer.

Took it to get it flashed.

Mechanic flashed it, but no change in lights.
Mechanic flashed as new install, still no change in lights.
Mechanic flashed as "as built info", and still no change in lights.
Mechanic ran self test, ABS passed with no codes but still, no change in lights.

Also, no codes showed at all for any system on the truck when self test done.

Now I'm lost as to where to proceed from here. Any suggestions?

Last edited by jgriffinemt; 09-04-2015 at 08:20 AM.
jgriffinemt is offline  
Old 09-09-2015, 06:33 AM
  #2  
Junior Member
Thread Starter
 
Join Date: Sep 2015
Posts: 3
Thanked 0 Times in 0 Posts
Default Hello

Hello? Anyone out there?
jgriffinemt is offline  
Old 09-09-2015, 08:15 AM
  #3  
Mark
iTrader: (1)
 
techrep's Avatar
 
Join Date: Jan 2009
Location: Va. Beach, VA.
Posts: 32,775
Thanked 1,644 Times in 1,484 Posts
Default

Where the hell is it snowing in Sept... Have you checked all the connectors to speed sensors..
techrep is online now  
The Following User Says Thank You to techrep For This Useful Post:
jgriffinemt (09-09-2015)
Old 09-09-2015, 09:20 AM
  #4  
Junior Member
Thread Starter
 
Join Date: Sep 2015
Posts: 3
Thanked 0 Times in 0 Posts
Default

It happened while it was snowing back in winter. Was quoted $1700 to replace module so instead I ordered it myself and put it in. Took to Ford to get it flashed for free. Much cheaper fix $279. I haven't checked all the speed sensors, I was told that if it was a sensor, the computer would flash a code for it.
jgriffinemt is offline  
Old 09-02-2016, 10:46 PM
  #5  
Junior Member
 
Join Date: Nov 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Lights

Hello you fix your problem with the lights? I have same problem
alfredoperezr is offline  
Old 10-16-2016, 05:10 PM
  #6  
Senior Member
 
Fordjunkync's Avatar
 
Join Date: Apr 2009
Posts: 285
Thanked 18 Times in 16 Posts
Default

Fordjunkync is offline  
Old 11-29-2016, 11:09 PM
  #7  
Junior Member
 
Join Date: Apr 2015
Posts: 2
Thanked 0 Times in 0 Posts
Default

Have same problem on 2009 F150. Did you ever resolve ?
FLBLACKPLAT is offline  
Old 11-30-2016, 12:42 PM
  #8  
Junior Member
 
Join Date: Nov 2011
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by FLBLACKPLAT View Post
Have same problem on 2009 F150. Did you ever resolve ?
sure resolved
my English its not good but let try explain.
the dealer for fix it the cost is 750$ replace abs plus labor...
i have a friend owner workshop he have a scanner and give around 5 codes error plus lights dashboard on.....then take off the complete abs module + pump....
take the pump (silver part) only connect direct battery car and test separate of the module (black part) is the pump run is good....the pump working. If the pump not working them buy an used in ebay and put your module together again and test......
if the pump not working, (its my problem) then going to www.myairbags.com and buy "module reset" i paid $89 and send by mail your module, they return a other module with your model of the car.....
after received i put the my pump + module received repair and the lights OFF and so happy only PAID 100$
good look my friend!!!!!!
alfredoperezr is offline  
Old 12-01-2016, 07:41 PM
  #9  
Certified Grumpasaurus
 
Join Date: Dec 2011
Location: Texas
Posts: 162
Thanked 16 Times in 15 Posts
Default

Just had the same problem with my 2009 last week. Waiting to get my module back from myairbags.com, hopefully by early next week.

MPD165
MPD165 is offline  
Old 12-02-2016, 09:26 PM
  #10  
Senior Member
 
Join Date: Dec 2009
Location: Mobile, Al
Posts: 638
Thanked 67 Times in 60 Posts
Default

Did you check the brake fluid level? My wife's Nissan Armada did something similar.... Brake Light, VDC Light and Slip light all came on. We had the brake system flushed a service or two ago and apparently the tech did not fill the brake fluid reservoir properly. Added a little fluid and all is good.
rrp0968 is offline  

Thread Tools
Search this Thread
Quick Reply: ABS light, Brake light, Check Brake System and anti skid indicators on analog readout


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: