Need audio experts! - Ford F150 Forum - Community of Ford Truck Fans



Stereo/Audio Come discuss all Ford F150 Stereo and Audio questions here!

Need audio experts!

Reply
 
 
 
Thread Tools Search this Thread
Old 09-02-2015, 01:30 AM   #1
Junior Member
Thread Starter
 
Join Date: Jul 2015
Posts: 26
Thanked 14 Times in 5 Posts
Default Need audio experts!

I have a 2015 F-150 XLT, its not the sony system, but it is the MyFord Touch 8" screen with Sync. Unfortunately I'm unable to find a solution for replacing the stock head since its the 8" MyFord Touch (idatalink tells me they don't think they will ever try to integrate). So i left the stock Head and I used the JBL MS-8 as my DSP. the front right and left speaker signal from the truck are full range signal so these are used for my inputs on the MS-8. From the DSP I go to 3 new Gladen amps, an XL-150c4, XL-275c2, and an SPL 1800c1. I have the Hertz Mille ML 1600 mid drivers in the front doors powered from the XL-275c2, the Hertz Mille ML 280 tweeters in the A Pillars off channels 1 and 2 of the XL-150c4, and Audison Voce 6.5" coax in the rear doors off channels 3 and 4 of the XL-150c4. The SPL 1800c1 powers 4 Audiomobile Evo 2410's under the rear seat (box still under construction). Currently everything is wired and fully hooked up except the subs, and the truck is fully sound deadened. I have used this MS-8 in one other truck with the same speakers but different amps. I had success with it, but was using an Alpine as my HU not the factory radio. My problem is that for most people the system probably sounds fine, but I feel like I'm lacking in some mid bass, and most importantly the music seems to sound more digitial than it should, almost like its a poor recording or overly compressed. I have ran several setups with MS-8 and have lowered the volume a lot before doing the mic calibration. This seems to have helped but not 100%. I have the sub and front door mids crossed at 65hz with 12db slope, the tweets crossed at 2000z with 12db slope, and the rear doors crossed at 65hz at 12db slope. Any suggestions? Im not sure if the factory head is the issue (all eq and crap off or set flat on head unit), or I just got lucky in my last setup and the MS-8 is junk? Im willing to run a different DSP, suggestions? Rockford 3sixty.3? Mosconi 6to8? Something else? Im in no way an expert tuner which is why I have the MS-8 to start. Thanks for any help you can offer!!!
Kalen427 is offline   Reply With Quote
Old 09-03-2015, 07:28 PM   #2
Senior Member
 
Join Date: Jan 2015
Posts: 125
Thanks: 0
Thanked 20 Times in 16 Posts
Default

Kalen, Sounds like you have a pretty nice setup. I can't really help you with the MS8 but it's very popular over at diymobileaudio.com. Maybe someone there could offer some help.

I also find this thread interesting:
https://www.f150forum.com/f118/anyon...305052/index5/

It seems user paulh3nry had issues with sound quality when playing MP3s after installing the JBL audio upgrade kit. I know it's not a fix, but it could have something to do with what your seeing.
dan02gt is offline   Reply With Quote
Old 09-04-2015, 12:20 AM   #3
Junior Member
Thread Starter
 
Join Date: Jul 2015
Posts: 26
Thanked 14 Times in 5 Posts
Default

Thanks for the input Dan. In my Tundra I had the Ms8 sounding pretty good, but truly it always seemed like it was still missing the natural warmth of the music. I haven't been able to make it sound as good as the Tundra did, but I had hours of messing with it logged in that truck. I have an extensive background in Car Audio and always shy'd away from the quick fix auto tune stuff, "because if its too good to be true...." So anyways, I ordered the Rockford 3sixty.3 today. Tuning by ear takes me weeks, but in the end I know it'll sound how I want, and I have to much $$$ in equipment to settle for anything less. I will do a build thread with pics after this weekend when I finalize the install.
Kalen427 is offline   Reply With Quote
Old 09-04-2015, 09:14 AM   #4
Senior Member
 
Join Date: Jan 2015
Posts: 125
Thanks: 0
Thanked 20 Times in 16 Posts
Default

Quote:
Originally Posted by Kalen427 View Post
Thanks for the input Dan. In my Tundra I had the Ms8 sounding pretty good, but truly it always seemed like it was still missing the natural warmth of the music. I haven't been able to make it sound as good as the Tundra did, but I had hours of messing with it logged in that truck. I have an extensive background in Car Audio and always shy'd away from the quick fix auto tune stuff, "because if its too good to be true...." So anyways, I ordered the Rockford 3sixty.3 today. Tuning by ear takes me weeks, but in the end I know it'll sound how I want, and I have to much $$$ in equipment to settle for anything less. I will do a build thread with pics after this weekend when I finalize the install.
I understand that. I had a Pioneer Double DIN in a previous car and tried the auto tune on it. My results were the same as yours. The music sounded lifeless. My experience with home theater auto tune has also been the same. I do hear good things about the Rockford DSP.
dan02gt is offline   Reply With Quote
Old 09-23-2015, 08:26 PM   #5
Junior Member
 
Join Date: Sep 2015
Posts: 6
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Kalen427 View Post
Thanks for the input Dan. In my Tundra I had the Ms8 sounding pretty good, but truly it always seemed like it was still missing the natural warmth of the music. I haven't been able to make it sound as good as the Tundra did, but I had hours of messing with it logged in that truck. I have an extensive background in Car Audio and always shy'd away from the quick fix auto tune stuff, "because if its too good to be true...." So anyways, I ordered the Rockford 3sixty.3 today. Tuning by ear takes me weeks, but in the end I know it'll sound how I want, and I have to much $$$ in equipment to settle for anything less. I will do a build thread with pics after this weekend when I finalize the install.
Kalen, how did the install go?
beekahx4 is offline   Reply With Quote
Old 09-24-2015, 12:26 PM   #6
Junior Member
 
Join Date: Sep 2015
Location: Denver
Posts: 10
Thanked 3 Times in 3 Posts
Default

What audio source? Can you tell a difference between CD/Sirius/FM?

I ask because the Sirius sounds slightly over compressed in this truck vs my last truck.
Sharpgypsy is offline   Reply With Quote
Old 10-25-2015, 04:19 AM   #7
Member
 
Join Date: Aug 2015
Posts: 93
Thanked 9 Times in 7 Posts
Default

Quote:
Originally Posted by Sharpgypsy View Post
What audio source? Can you tell a difference between CD/Sirius/FM?

I ask because the Sirius sounds slightly over compressed in this truck vs my last truck.


With that fake engine noise @ the speakers & the way it messes up Sirius even more than it already is; I won't be keeping my Sirius account much longer !!
'15 Lariat is offline   Reply With Quote
Old 10-25-2015, 10:12 AM   #8
WindowGuy
 
Join Date: Dec 2012
Location: Indianapolis
Posts: 1,079
Thanked 95 Times in 91 Posts
Default

I'm not an expert, but it seems like the head unit might be the problem.
jkenprice1 is offline   Reply With Quote
Old 11-25-2015, 07:54 AM   #9
Member
 
Join Date: Sep 2015
Posts: 75
Thanks: 0
Thanked 5 Times in 3 Posts
Default

Any updates from the op?
kevreh is offline   Reply With Quote
Old 11-25-2015, 10:17 AM   #10
Senior Member
 
Join Date: Oct 2015
Location: Nashville, TN
Posts: 100
Thanked 8 Times in 6 Posts
Default

Does the MS8 have an aux input? I would try going directly into the MS8 to see if it sounds different. IE, bypass the head unit.

Of course, at this point, you probably have your RF. Did you notice a difference?

Brandon
cbrandonb is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
2015 Lariat Crew Cab - Lease Upgrade iJeffG Stereo/Audio 6 10-26-2015 02:20 PM
Crossover locations Brandon22685 Stereo/Audio 6 09-29-2015 10:07 PM
Strange sound rha748 General F150 Discussion 2 09-29-2015 03:10 PM
Any Sony replacement speaker reviews? James Cole 2015 - Present Ford F150 0 09-27-2015 03:16 PM
Left speaker fades in and out fordfxr1 General F150 Discussion 4 09-25-2015 11:05 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 06:55 AM.


Copyright 2006 - 2017 F150Forum.com We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: