Topic Sponsor
General F150 Discussion General Ford F150 truck discussions and questions
Sponsored by:
Sponsored by:

"The USB device requires too much power. Please remove."

 
Old 12-12-2016, 07:49 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Dec 2016
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default "The USB device requires too much power. Please remove."

I just purchased a 2016 Ford F150 and went to plug in my USB drive that I have been listening to music on for the last 5 years in my previous truck, which was a 2011 Ford F150. It worked fine in my 2011 Ford F150 but when I plug it into my new truck I get the error "The USB device requires too much power. Please remove". I tried to plug in other USB devices and they all worked. They were an Apple iPhone 5s, a Samsung Galaxy S5, and an Apple iPod mini 2. There were no issues when I plugged these into the USB port (I've tried both ports with all simulations and get the same results). The USB drive I am using is a SanDisk low profile 32GB USB 3.0 drive. Has anyone else had this issue or have any advice?
wjolivarez is offline  
Old 12-13-2016, 02:02 PM
  #2  
Ford Customer Service
 
FordIVTteam's Avatar
 
Join Date: Jul 2013
Posts: 1,906
Received 300 Likes on 191 Posts
Default

Hi wjolivarez,

Congrats on the new truck! Does it have basic SYNC or SYNC 3: owner.ford.com/how-tos/sync-technology/all/setup/how-to-identify-your-sync-version.html

Shaay
FordIVTteam is offline  
Old 12-13-2016, 02:07 PM
  #3  
Junior Member
Thread Starter
 
Join Date: Dec 2016
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by FordIVTteam View Post
Hi wjolivarez,

Congrats on the new truck! Does it have basic SYNC or SYNC 3: owner.ford.com/how-tos/sync-technology/all/setup/how-to-identify-your-sync-version.html
Hello Shaay,

It has SYNC 3.

Thanks.
Will
wjolivarez is offline  
Old 12-13-2016, 04:37 PM
  #4  
Ford Customer Service
 
FordIVTteam's Avatar
 
Join Date: Jul 2013
Posts: 1,906
Received 300 Likes on 191 Posts
Default

Thanks, Will. Can you please send your VIN in a private message? I'd like to look into this for you.

Shaay
FordIVTteam is offline  
Old 12-14-2016, 08:27 PM
  #5  
Junior Member
Thread Starter
 
Join Date: Dec 2016
Posts: 3
Likes: 0
Received 0 Likes on 0 Posts
Default

Shaay,

I sent the VIN in a private message to you. Please let me k is if you got it. I want to make sure I sent it to the right person. Thanks.
wjolivarez is offline  
Old 12-15-2016, 09:15 AM
  #6  
Ford Customer Service
 
FordIVTteam's Avatar
 
Join Date: Jul 2013
Posts: 1,906
Received 300 Likes on 191 Posts
Default

Thanks, wjolivarez. I received your PM and will respond shortly.

Shaay
FordIVTteam is offline  
Old 12-27-2016, 04:43 PM
  #7  
Junior Member
 
Join Date: Dec 2016
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

Originally Posted by FordIVTteam View Post
Thanks, wjolivarez. I received your PM and will respond shortly.

Shaay
Did you find a solution? I have a 2016 Mustang GT, with Sync 3 & it does the same thing. Just trying to see if it's a fixable issue.
MsKhrys is offline  
Old 12-28-2016, 10:34 AM
  #8  
Ford Customer Service
 
FordIVTteam's Avatar
 
Join Date: Jul 2013
Posts: 1,906
Received 300 Likes on 191 Posts
Default

Hi MsKhrys,

The OP was able to use other USB devices without any issues. He reformatted the one in question and still received the same issue. He tried wiggling the connection and the drive worked. He's currently going to the service center to have them look into it.

Have you tried other USB drives? I also suggest that you go to the dealer to make sure there are any loose connections.

Shaay
FordIVTteam is offline  
Old 02-18-2017, 09:28 PM
  #9  
Junior Member
 
Join Date: Jan 2017
Posts: 9
Received 1 Like on 1 Post
Default

i am getting the same error message. the same usb stick worked flawlessly in my previous 2016 f150 with sync 1, but my new 2016 f150 with sync 3 isn't playing nice.

dealer is looking into it but some help from this forum would be appreciated. thank you
lucati is offline  
Old 04-27-2017, 02:28 PM
  #10  
Junior Member
 
Join Date: Apr 2017
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default

I just got a 2017 F150 with the sync 3 and I had a older 2.0 thumb drive I plugged in and my phone, then all of a sudden the ports stopped working. About 30 min later they started to work again fine, but I didn't plug the drive back in thinking it may have caused an issue. I bought a sandisk 3.0 64gb drive, the tiny one, and plugged it and I get the same power error. I bought a 2.0 and waiting for that in the mail thinking the 3.0 wasn't comparable. My iPhone 7 plus still works fine.
Ibanez Lefty Club is offline  

Thread Tools
Search this Thread

Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: