Topic Sponsor
General F150 Discussion General Ford F150 truck discussions and questions
Sponsored by:
Sponsored by:

Ecoboost Lawsuit - Owners Claim Engine Defective

 
Old 05-15-2013, 01:21 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Nov 2012
Posts: 20
Received 3 Likes on 3 Posts
Default Ecoboost Lawsuit - Owners Claim Engine Defective

Ecoboost Lawsuit

As a guy who's already had his 2012 in the shop twice because of these exact problems (which STILL continue), Ford better find a fix quick. It looks like I'm not the only one having issues with the ecoboost cutting power and having bad vibrations.

Anyone else who has had repeated problems with this rather severe safety issue, I encourage you to take a minute or two and file a complaint with the NHTSA: Complaint Form

Personally, I've had it with the ecoboost. It sucks driving this truck because when you get on the gas, you have no clue if you're going to go anywhere. Definitely considering going back to the dealer, and seeing what I can do with the lemon laws in NC.

Last edited by jdlev; 05-15-2013 at 01:33 PM.
jdlev is offline  
Old 05-15-2013, 02:20 PM
  #2  
Junior Member
Thread Starter
 
Join Date: Nov 2012
Posts: 20
Received 3 Likes on 3 Posts
Default

Found this article on a supposed fix from ford. Anyone tried it yet that's had similar issues with their ecoboost? Doesn't seem like a great fix to me? Doesn't it defeat the purpose of the turbo air cooler to just cover it up?

Anyways...here's the service announcement from ford: Service Announcement On Ecoboost

Edit: Update to the service fix. Ford's released another update (though I haven't found it). The fix is actually replacing the intercooler rather than just covering the old intercooler with an air deflector. The new intercooler also has an air deflector. Hopefully, this fixes the issue.

Last edited by jdlev; 05-15-2013 at 02:32 PM.
jdlev is offline  
The following users liked this post:
bk117wrench (05-16-2013)
Old 05-15-2013, 02:57 PM
  #3  
Senior Member
 
Join Date: Apr 2013
Location: Tulsa
Posts: 296
Received 17 Likes on 16 Posts
Default

Sounds like you need to jump and the class action suit because after that "fix" it is going to lower the horse power of the engine because now you have a nonfunctional inter cooler. Then you'll have false advertisement on the power, torque and towing weight
Bbdaddy1221 is offline  
Old 05-15-2013, 03:09 PM
  #4  
Senior Member
 
gregsf150stx's Avatar
 
Join Date: Nov 2010
Location: TN
Posts: 4,562
Received 428 Likes on 337 Posts
Default

This must be the THIRD thread already about this. TODAY.
gregsf150stx is offline  
The following users liked this post:
Marc D (05-27-2013)
Old 05-15-2013, 03:51 PM
  #5  
Junior Member
Thread Starter
 
Join Date: Nov 2012
Posts: 20
Received 3 Likes on 3 Posts
Default

Originally Posted by gregsf150stx View Post
This must be the THIRD thread already about this. TODAY.
Do you have a point, or are you just trolling? I wish I'd had all the information in this thread 3 months ago. I'm pretty sure if you just spent $40k on a new truck that doesn't work, you'd like the solution to be easy to find.
jdlev is offline  
The following users liked this post:
wizwor (08-22-2018)
Old 05-15-2013, 03:53 PM
  #6  
Junior Member
Thread Starter
 
Join Date: Nov 2012
Posts: 20
Received 3 Likes on 3 Posts
Default

Originally Posted by Bbdaddy1221 View Post
Sounds like you need to jump and the class action suit because after that "fix" it is going to lower the horse power of the engine because now you have a nonfunctional inter cooler. Then you'll have false advertisement on the power, torque and towing weight
I'm pretty sure this glitch has pissed a lot of people off. I know Ford had at least a full production year with the ecoboost in the F150 and other models prior to my model year (2012) to get this thing right.

Oh well...maybe the third time to the dealership service dept will be the charm.
jdlev is offline  
Old 05-15-2013, 08:46 PM
  #7  
Senior Member
 
Join Date: Jan 2013
Location: Omaha, NE
Posts: 231
Received 13 Likes on 12 Posts
Default

Originally Posted by jdlev View Post
Do you have a point, or are you just trolling? I wish I'd had all the information in this thread 3 months ago. I'm pretty sure if you just spent $40k on a new truck that doesn't work, you'd like the solution to be easy to find.
Maybe the point was to keep it in a thread already created instead of starting a bunch of new ones?
Clone is offline  
The following users liked this post:
Pond Hockey (05-16-2013)
Old 05-15-2013, 08:53 PM
  #8  
One Clean Machine
iTrader: (5)
 
Toddman38's Avatar
 
Join Date: Sep 2012
Location: St. Louis, MO
Posts: 10,461
Received 1,586 Likes on 1,330 Posts
Default

Unfortunately, to many people on this site, have nothing better to do than Troll the threads, and just complain instead of truly helping others out, or keep their options to themselves! Like how many thread are there on leveling kits, and tires! Gimme a Break!
Toddman38 is offline  
The following users liked this post:
wizwor (08-22-2018)
Old 05-15-2013, 09:01 PM
  #9  
Senior Member
 
Join Date: Jan 2013
Location: Omaha, NE
Posts: 231
Received 13 Likes on 12 Posts
Default

Originally Posted by Toddman34 View Post
Unfortunately, to many people on this site, have nothing better to do than Troll the threads, and just complain instead of truly helping others out, or keep their options to themselves! Like how many thread are there on leveling kits, and tires! Gimme a Break!
Good Point...
I hope those with issues can get them corrected...I read about it all before I purchased and I guess I am holding out hope the 2013's are going to be alright.
Clone is offline  
Old 05-15-2013, 09:23 PM
  #10  
One Clean Machine
iTrader: (5)
 
Toddman38's Avatar
 
Join Date: Sep 2012
Location: St. Louis, MO
Posts: 10,461
Received 1,586 Likes on 1,330 Posts
Default

Originally Posted by Clone View Post
Good Point...
I hope those with issues can get them corrected...I read about it all before I purchased and I guess I am holding out hope the 2013's are going to be alright.
Pacman24, has a 2013 KR and had it happen with the condensation issue, TSB was applied to his, and his still has the problem, so the 13's aren't fixed either! Its wierd how some have it, and some dont!
Toddman38 is offline  

Thread Tools
Search this Thread
Quick Reply: Ecoboost Lawsuit - Owners Claim Engine Defective


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: