Topic Sponsor
Pre- 1987 / Classic Corner Have a classic Ford F150 truck? Want a classic? Discuss your pre-1987 Ford F150 truck.

86 f150 5.0 EFI hesitating and sometimes stalls

 
Old 12-11-2018, 10:27 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Dec 2018
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default 86 f150 5.0 EFI hesitating and sometimes stalls

Once the truck gets to operating temperature it hesitates and sometimes stalls, the stalling happens mostly in reverse and it only happens in drive if you hit a certain spot in the gas pedal when taking off. The truck starts right back up every time. Once you get past the little hesitation she is smooth as silk. The TPS is new, the IAC valve is new and the MAP sensor is new. The temperature gauge doesn't work the switch might be bad but I think the truck would run like crap all the time if that were the case... It's easy on gas, It doesn't smoke at all, great acceleration, it's just that one spot as soon as I put the weight of my foot on the gas pedal. It's all I've got to drive so I've gotten pretty good a missing that spot, but driving it is only going to make things worse. I read in another forum that the transmission fluid/filter could have something to do with it (something about the filter falling off and laying in the pan?). I know my way around these trucks pretty well and this is the only one if the 12 I have owned that stumped me and im losing sleep over it any input or advice would be greatly appreciated!
Kirby93 is offline  
Old 12-22-2018, 12:01 AM
  #2  
Old Timer
 
Join Date: Mar 2016
Location: Somewhere In North America
Posts: 384
Received 16 Likes on 15 Posts
Default

Have you checked to see what the computer knows? (Fault Codes)
vjsimone is offline  
Old 12-22-2018, 02:15 PM
  #3  
Bronco Guru
 
Steve83's Avatar
 
Join Date: Jan 2018
Location: Memphis, TN, Earth, Milky Way
Posts: 3,900
Received 452 Likes on 413 Posts
Default

Originally Posted by Kirby93 View Post
...the truck...
We can help you MUCH more if we can review all the truck's details & history in your signature, as this caption explains:


(phone app link)
Originally Posted by Kirby93 View Post
The TPS is new, the IAC valve is new and the MAP sensor is new.
Why? When (time/miles)? What was wrong with EACH of the original parts? Did each new one pass the same test that the original failed? What (brand/PN/source) is each replacement?
Originally Posted by Kirby93 View Post
The temperature gauge doesn't work the switch might be bad but I think the truck would run like crap all the time if that were the case.
The gauges have nothing to do with engine management. The EEC uses the ACT & ECT to read temperature, and each one needs to be tested, as this caption explains:


(phone app link)
Steve83 is offline  
 


Thread Tools
Search this Thread
Quick Reply: 86 f150 5.0 EFI hesitating and sometimes stalls


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: