Parasitic drag on battery....Need some help. - Ford F150 Forum - Community of Ford Truck Fans

Topic Sponsor
Member meet ups! If you’ve met up with other member(s) of the forum, post pictures of it here!
Sponsored by:
Sponsored by:

Parasitic drag on battery....Need some help.

 
Old 09-11-2018, 07:23 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Sep 2018
Location: Goose Bay ,Labrador Canada
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Parasitic drag on battery....Need some help.

Hey all, got a 2012 fx4 5.0 litre with some troubles. Battery died on me a while back and seemed to be weak so i was considering a new one anyway and changed it. Day or so later it my truck would not start. Did some trouble shooting and found a circuit running thats connected to the PCM relay, i can hear something running so i found what circuit it was and removes the relay and noise goes away. I am hearing the sound around the transmission area mostly, sounds like a electric pump or fan running very faint but its there. Seems lile its on top of the transmission too but not sure . I was told maybe the airbag module which is in that area ..but need some help in locating the issue. Any ideas?
SilverfoxFX4 is offline  
Old 01-09-2019, 11:33 AM
  #2  
Junior Member
 
Join Date: Jan 2019
Posts: 6
Thanked 0 Times in 0 Posts
Default

Any luck with this? I am having the same issue on my 2014 5.0.
c-m-r is offline  
 


Thread Tools
Search this Thread
Quick Reply: Parasitic drag on battery....Need some help.


Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: