Topic Sponsor
Performance, Tuning, and (LEGAL) Racing Post discussions about increasing performance, capabilities, and racing. ****WARNING**** Street racing or illegal activities will be removed and potential bans will be handed out.

Whipple Questions

 
Old 02-05-2019, 08:29 AM
  #11  
Senior Member
 
BadCon's Avatar
 
Join Date: Jul 2018
Posts: 627
Received 157 Likes on 119 Posts
Default

You talking about max tow, or just the tow package? I think the max tow kit comes with the slightly larger radiator, but its hit and miss and hard to clarify using build sheets and I'm not sure if its a max tow only item or if some engines get it by default. That said tasca parts lists two radiators or my truck at least, and the alleged larger of the two is only a couple hundred bucks, so it could be easy to add aftermarket if in fact the truck you are looking at doesn't come with it. I'm not sure if the radiator is any thicker...I've been unable to find any dimensions for any of the radiators.

I honestly don't think its going to make a difference. Whatever radiator is in my none max tow truck does a fine job of keeping my supercharged truck cool in Texas heat. I've done some modifications to keep the temps as low as possible to avoid deto, such as a Reische thermostat and cutting a hole in my hood, but even before doing those modifications it never ran hotter then stock.

Since doing the thermostat it rarely breaks 195 degrees, and is usually right around 190, which is almost too cool if you ask me. I was under the impression the trucks had a 180 degree t-stat by defualt, which is why I went with the 170*, but when I removed the factory unit it was stamped with 190*. If I did it again I'd find a factory 180* t-stat, which allegedly exists somewhere.

Last edited by BadCon; 02-05-2019 at 08:31 AM.
BadCon is offline  
Old 04-15-2019, 07:23 PM
  #12  
Yup
Thread Starter
 
Sharkhunt's Avatar
 
Join Date: Jul 2018
Location: Dallas, TX
Posts: 235
Received 53 Likes on 36 Posts
Default

So far, I am loving my Whipple setup. Iíve got about 1000 miles on it so far.

Do any of you with blowers have a whistle at about 25% throttle? Iíve read about it in other threads, but I donít think Iíve seen an explanation or a fix. Any ideas?

I donít hear the whistle at tip in, but I do between about 15-25%. After that, I donít hear it. It almost sounds like a valve closing when I push the throttle past that.
Sharkhunt is offline  
Old 04-15-2019, 07:26 PM
  #13  
Senior Member
 
TX-Ripper's Avatar
 
Join Date: Apr 2016
Location: SE Texas
Posts: 1,429
Received 247 Likes on 219 Posts
Default

Originally Posted by Sharkhunt View Post
So far, I am loving my Whipple setup. Iíve got about 1000 miles on it so far.

Do any of you with blowers have a whistle at about 25% throttle? Iíve read about it in other threads, but I donít think Iíve seen an explanation or a fix. Any ideas?

I donít hear the whistle at tip in, but I do between about 15-25%. After that, I donít hear it. It almost sounds like a valve closing when I push the throttle past that.
i think what your describing is the bypass valve doing itís thing.
TX-Ripper is offline  
Old 04-15-2019, 07:51 PM
  #14  
Yup
Thread Starter
 
Sharkhunt's Avatar
 
Join Date: Jul 2018
Location: Dallas, TX
Posts: 235
Received 53 Likes on 36 Posts
Default

Originally Posted by TX-Ripper View Post
i think what your describing is the bypass valve doing itís thing.
Ill go with that. The noise doesnít sound wrong, itís just much more pronounced that it was before I was boosted.
Sharkhunt is offline  

Thread Tools
Search this Thread
Quick Reply: Whipple Questions


Contact Us - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: