EDGE 2.0 EB sluggish after repairs - Ford F150 Forum - Community of Ford Truck Fans

Topic Sponsor
Engine / Drivetrain Talk 6 or 8 Cylinders? Come talk about it.

EDGE 2.0 EB sluggish after repairs

Reply

 
 
 
Old 04-13-2018, 09:10 AM
  #1  
Senior Member
Thread Starter
 
k-stater88's Avatar
 
Join Date: Feb 2010
Location: Kansas
Posts: 243
Thanked 15 Times in 11 Posts
Default EDGE 2.0 EB sluggish after repairs

Hey guys. I know this isn't an F-150, but the Edge forum seems a bit dormant. We sent our '12 Edge ecoboost in for NASTY fuel in oil smell that was caking our cabin filter and blowing horribly into the cab. I got the car back and took it on a 90 mile trip. I've been telling my wife over the last few thousand miles that the edge just seems like it needs a little more help to get going than when we originally bought it. For the first time, I noticed that it was struggling to maintain cruise control speed. If I set it at 71, it would hold at 69-70 and any little tiny overpass would lose up to 4 mph and then kick down granted into a headwind. We've been up hills and mountains and into headwinds worse than today with this car and never noticed this kind of issue. No error codes, but with the crap mpg and perceived slight power loss, any ideas of what it could be?

* vac line from dealer troubleshooting?
* turbo issue?
* fuel/air mixture off or injector issue?

The dealer swears twice that there are no pressurized leaks nor injector issues. Just trying to decide if I have a major issue on my hands or not. just hit 80,000 miles today.
k-stater88 is offline  
Reply With Quote
 
 
 


Thread Tools
Search this Thread

Contact Us Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: