ok seafoam and replaced egr regulator - Ford F150 Forum - Community of Ford Truck Fans



1987 - 1996 F150 Still running strong! Talk about your 8th and 9th generation Ford F150 trucks.

ok seafoam and replaced egr regulator

Reply
 
 
 
Thread Tools Search this Thread
Old 06-05-2010, 11:05 PM   #1
Senior Member
Thread Starter
 
truecountry's Avatar
 
Join Date: May 2010
Location: kerrlake
Posts: 150
Thanks: 0
Thanked 0 Times in 0 Posts
Default ok seafoam and replaced egr regulator

ok seafoamed my truck ... couldnt stall it and i was pouring it in .. cut it off waited 25 mins cranked it up and yuppppppppppppp smoked like a diesel with bad injectors ,,,, 30 mins later cleared up ... drove it fine... replaced egr vacuum regulator unhooked battery cleared codes and run koer got 2 codes 41 77 and i turned steering wheel waited and opened throttle wide open ,,,lol my thing is i still notice the stumble in accellaration.. i might get that tps anyway to rule it out ...fuel tank is half full and seafoamed it also and crankcase too ...was going to do the timing bump but ill wait til i get oil changed and tps .. the stumble in throttle makes me wonder... but before i buy anything im driving it to see if it clears up too
truecountry is offline   Reply With Quote
Old 06-05-2010, 11:30 PM   #2
Administrator
 
ymeski56's Avatar
 
Join Date: Jul 2008
Location: Long Beach Calimexifornia
Posts: 34,178
Thanked 961 Times in 540 Posts
Default

Quote:
Originally Posted by truecountry View Post
ok seafoamed my truck ... couldnt stall it and i was pouring it in .. cut it off waited 25 mins cranked it up and yuppppppppppppp smoked like a diesel with bad injectors ,,,, 30 mins later cleared up ... drove it fine... replaced egr vacuum regulator unhooked battery cleared codes and run koer got 2 codes 41 77 and i turned steering wheel waited and opened throttle wide open ,,,lol my thing is i still notice the stumble in accellaration.. i might get that tps anyway to rule it out ...fuel tank is half full and seafoamed it also and crankcase too ...was going to do the timing bump but ill wait til i get oil changed and tps .. the stumble in throttle makes me wonder... but before i buy anything im driving it to see if it clears up too
No bump till the error codes are gone. Sounds like 77 is still op. error (right thing, wring time). How old's the O2 sensor? Is it connected?
ymeski56 is offline   Reply With Quote
Old 06-05-2010, 11:35 PM   #3
Senior Member
Thread Starter
 
truecountry's Avatar
 
Join Date: May 2010
Location: kerrlake
Posts: 150
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i just got the truck so im following behind someone else
truecountry is offline   Reply With Quote
Old 06-05-2010, 11:39 PM   #4
Administrator
 
ymeski56's Avatar
 
Join Date: Jul 2008
Location: Long Beach Calimexifornia
Posts: 34,178
Thanked 961 Times in 540 Posts
Default

Quote:
Originally Posted by truecountry View Post
i just got the truck so im following behind someone else
41 means the o2's pooched or possibly disconnected.
ymeski56 is offline   Reply With Quote
Old 06-05-2010, 11:41 PM   #5
Senior Member
Thread Starter
 
truecountry's Avatar
 
Join Date: May 2010
Location: kerrlake
Posts: 150
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i will see about o2 sensors tomorrow its twin lines same converter but duel in and out under passenger side floor board
truecountry is offline   Reply With Quote
Old 06-06-2010, 01:31 PM   #6
Senior Member
Thread Starter
 
truecountry's Avatar
 
Join Date: May 2010
Location: kerrlake
Posts: 150
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok did a quick check o2 is connected and looks old , after doing some reading i have a lean condition maybe a vacuum leak , remeber i said i heard a leak upon shutting engine off , and i found it today i feel sorta dumb it was pvc wasnt hooked in valve cover lololol.. going to retest
truecountry is offline   Reply With Quote
Old 06-06-2010, 03:04 PM   #7
Senior Member
 
91whitelariat's Avatar
 
Join Date: Jan 2010
Location: Gray, GA
Posts: 113
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I want to seafoam my truck, but its a 91 4.9 with 241,000 miles and im scared its gonna loosen up some grit in the engine and start an oil leak. I am already leaking oil a little bit, and dont wana make it worse. Should i do it? Is it 1 can in brake booster vacuum and 1/2 in oil and 1/2 in gas?
91whitelariat is offline   Reply With Quote
Old 06-06-2010, 05:33 PM   #8
Administrator
 
ymeski56's Avatar
 
Join Date: Jul 2008
Location: Long Beach Calimexifornia
Posts: 34,178
Thanked 961 Times in 540 Posts
Default

Quote:
Originally Posted by truecountry View Post
ok did a quick check o2 is connected and looks old , after doing some reading i have a lean condition maybe a vacuum leak , remeber i said i heard a leak upon shutting engine off , and i found it today i feel sorta dumb it was pvc wasnt hooked in valve cover lololol.. going to retest
If you want decent MPG, replace the o2!!!
ymeski56 is offline   Reply With Quote
Old 06-06-2010, 05:40 PM   #9
Administrator
 
ymeski56's Avatar
 
Join Date: Jul 2008
Location: Long Beach Calimexifornia
Posts: 34,178
Thanked 961 Times in 540 Posts
Default

Quote:
Originally Posted by 91whitelariat View Post
I want to seafoam my truck, but its a 91 4.9 with 241,000 miles and im scared its gonna loosen up some grit in the engine and start an oil leak. I am already leaking oil a little bit, and dont wana make it worse. Should i do it? Is it 1 can in brake booster vacuum and 1/2 in oil and 1/2 in gas?
Oil leaks, are oil leaks! Fix em. You'd rather leave sludge & carbon build up in the engine?? 1/3,1/3,1/3 can. You'd be suprised at how many pan & cover leaks require just snugging the bolts to spec.! https://www.f150forum.com/f33/how-se...-1991-a-31505/

Last edited by ymeski56; 06-06-2010 at 05:43 PM.
ymeski56 is offline   Reply With Quote
Old 06-07-2010, 01:42 AM   #10
Senior Member
 
91whitelariat's Avatar
 
Join Date: Jan 2010
Location: Gray, GA
Posts: 113
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The only problem is we cant find the oil leakes, its not too bad about 1 qt every 2.5 weeks, but we replaced valve cover and upper gaskets. I think i am gonna find somebody with a torque wrench and tighten up all bolts on pan and stuff to spec. I just got outta school for summer so i will prolly do seafoam this week and see what goes down...My truck already runs decent with 241,000 miles so i cant imagine it being a huge miracle, but maybe?
91whitelariat is offline   Reply With Quote
 
 
Reply

Related Topics
Thread Thread Starter Forum Replies Last Post
Rough Idle At Operating Temp While In Gear ericarrendale 1997 - 2003 Ford F150 11 09-15-2015 04:56 PM
2009 -2014 F150 XLT Crew 4WD "LT C-Load Tire Option" Mike Up Towing/ Hauling/ Plowing 24 09-15-2015 01:24 AM
2000 5.4 leaking oil at crossover/Im Matthewb 1997 - 2003 Ford F150 0 09-05-2015 06:50 PM
Egr tube hitting firewall? ruckus226 General F150 Discussion 8 09-03-2015 11:22 AM
Egr restrictor plate 97green 1987 - 1996 F150 0 09-02-2015 11:58 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT -4. The time now is 01:52 PM.


Copyright 2006 - 2017 F150Forum.com We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: