Go Back   Ford F150 Forum - Community of Ford Truck Fans > Members List
Sign in using an external account
Register Forgot Password?


kcackler kcackler is offline

Junior Member

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. jrmr7374
    09-04-2011 04:43 PM - permalink
    jrmr7374
    by the way i replaced those parts in april and approx june it started the problem. could it be trash in tank causing a fuel flow problem
  2. jrmr7374
    09-04-2011 04:40 PM - permalink
    jrmr7374
    dude i have a 99 v6 4.2 that at different speeds the gas pedal goes soft and the engine does not respond like it is off. i let off pedal and it the engine returns normal. i have replaced pump and filter but it sat up for 2 years. what do you think.

Statistics

Total Posts
Visitor Messages
Total Thanks
General Information
  • Last Activity: 07-04-2012 08:37 AM
  • Join Date: 09-01-2011

Mentions

No results to display...

Feedback Score

iTrader Profile Recent Ratings
Feedback Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
View Complete Feedbacks for kcackler
  Past
Month
Past
6 Months
Past
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0
Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 02:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.