Go Back   Ford F150 Forum - Community of Ford Truck Fans > CJS F-1
Sign in using an external account
Register Forgot Password?


Conversation Between CJS F-1 and $pitt04fx4
Showing Visitor Messages 1 to 3 of 3
  1. $pitt04fx4
    02-21-2012 11:38 PM - permalink
    $pitt04fx4
    Thanks for the post! I went through the clogged cats deal after a coil pack went bad and unburnt gas poored into the exhaust. It's a totally diff experiance this time round, but it is fixed now! It was a bad MAF sensor that the diagnostic computers didn't read as bad. Thanks again!
  2. CJS F-1
    02-21-2012 08:26 PM - permalink
    CJS F-1
    this problem happened to 2 of my buddies both had 5.4 v8 4x4 the one truck had clogged cat converters and the other truck had a electrical or sensor issue so it could be any of those two things. both trucks had under 70,000 miles when this happened.
  3. $pitt04fx4
    02-14-2012 10:14 PM - permalink
    $pitt04fx4
    Hi, I have the exact same problem! High rpm and full throttle no power, it hits 5000 rpm...no go! My trans was just rebuit because of a o/d snap ring snapping. It started after my trans was done!? Had it rebuit by a diff shop...still doing it! I'm going crazy over this! I will let u know what it is if I EVER figure this out? Please do the same. Thanks and good luck!
Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 04:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.