Go Back   Ford F150 Forum - Community of Ford Truck Fans > 1ATony
Sign in using an external account
Register Forgot Password?


Conversation Between 1ATony and joshual89
Showing Visitor Messages 1 to 7 of 7
  1. 1ATony
    04-11-2012 09:09 AM - permalink
    1ATony
    I'm not 100% sure that's what's causing this issue, but you might want to see if it's working right. Usually when they go the truck will surge up and down while at idle, or it may leap forward while at a stop.
  2. joshual89
    04-10-2012 01:07 PM - permalink
    joshual89
    Well how would I fix that
  3. 1ATony
    04-09-2012 09:02 AM - permalink
    1ATony
    It shouldn't it sounds like it might me running rich.
  4. joshual89
    04-06-2012 04:55 PM - permalink
    joshual89
    would the egr valve cause it to back fire
  5. joshual89
    04-06-2012 03:54 PM - permalink
    joshual89
    well when it warms up is when it dies but i dont know what would cause it and it takes a few minutes for me to get it to even start
  6. 1ATony
    04-06-2012 03:45 PM - permalink
    1ATony
    If it has check engine light one, you should check the code to see if it points you in a direction. If it's a power loss issue once it heats up it could be a bad EGR valve, or possibly a bad cat if you start to lose power once you start driving and it warms up.
  7. joshual89
    04-06-2012 03:34 PM - permalink
    joshual89
    hey man i was wondering if u could help me figure out what is wrong with my truck it is a 88 ford f150 5.8 fuel injected when it warms up it will not stay running
Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 08:15 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.