Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > How-To Section > Engine & Drivetrain
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 10-28-2012, 07:37 AM   #1
Junior Member
 
Join Date: Jun 2011
Location: South LA
Posts: 4
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question 89' F150 fuel problems

swb, 5speed, 5.0litre. running great, all of the sudden, a "backfire" maybe, burb? started sputtering, jumping, wanting to die. was told fuel pump on it's way out. replaced the pump on the frame rail hoping it was the issue. old one had good fluid flow(gravity) on the input, no output at all. now the new one??? hear it or... with key on till it meets psi set point, no crank. fixing to check output, maybe input too. any suggestions?
jconner is offline   Reply With Quote
Old 10-28-2012, 07:37 AM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 12:56 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.