Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > How-To Section > Engine & Drivetrain
Sign in using an external account
Register Forgot Password?


Welcome to F150 Forum!
Welcome to F150 Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 01-12-2014, 08:11 AM   #1
Junior Member
 
Join Date: Jan 2014
Posts: 5
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 89 f150 2wd 302 fuel issues

89 f150 2wd 302 wont start I think it might be the fuel pump by the way it acts it was starting fine the other day but was having issues staying started it would just stall out now it won't start at all I would like to know if there is anything I should check or try before I say it's the fuel pump and do all of that bs any help is greatly appreciated
Thank you
acoden21 is offline   Reply With Quote
Old 01-29-2014, 07:55 AM   #2
Member
 
Join Date: Jun 2012
Location: northwest new mexico
Posts: 44
Mentioned: 0 Post(s)
Thanks: 2
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Ya it sounds like the fuel pump to me but I would also check your fuel filter to make sure that it is not clogged, and also check your FPR.
regulater2626 is offline   Reply With Quote
Old 01-30-2014, 06:40 PM   #3
Junior Member
 
Join Date: Jan 2014
Posts: 5
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Changed the fuel filter and the high pressure pump in the frame did not fix the problem another symptom was it is back firing under the hood with a pop ping kind of sound
acoden21 is offline   Reply With Quote
Old 01-30-2014, 06:49 PM   #4
Junior Member
 
Join Date: Jan 2014
Posts: 5
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Changed the high pressure pump on the frame and the fuel filter I also found it back firing under the hood with a pop ping sound that's only when it is running bad and dying
acoden21 is offline   Reply With Quote
Old 01-30-2014, 06:50 PM   #5
Junior Member
 
Join Date: Jan 2014
Posts: 5
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Sorry for the duplicates wasn't sure it went threw
acoden21 is offline   Reply With Quote
Old 02-25-2014, 11:23 AM   #6
rookie
 
Join Date: Aug 2012
Posts: 91
Mentioned: 0 Post(s)
Thanks: 3
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Default

what codes is it throwing? I'm thinking it is the fuel pressure regulator or the timing skipped. Check the codes first though.
macka is offline   Reply With Quote
Old 02-25-2014, 11:23 AM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


 

The Mustang Source
All times are GMT -4. The time now is 03:16 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.5.2
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.