Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > 1987 - 1996 F150 > Electrical
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 11-20-2013, 05:07 PM   #1
Junior Member
 
Join Date: Nov 2013
Posts: 5
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Frustration. '91 F150

I have heard and read awesome things about this forum... I am an avid owner of many different F-Series trucks over the years from an '81 to '06 in various configurations. I am seriously in need of some direction from y'all on this '91 I am buying. None of the interior or exterior lights work, neither does the radio. The blower fan works though, so the cab isn't totally void of power. Where do I start? Should I pay someone to diag and fix??? Direction... Please?
okieiniowa78 is offline   Reply With Quote
Old 11-20-2013, 06:18 PM   #2
Senior Member
 
Forge-World-FORD's Avatar
 
Join Date: Jun 2011
Posts: 2,364
Mentioned: 0 Post(s)
Thanks: 0
Thanked 101 Times in 98 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by okieiniowa78 View Post
I have heard and read awesome things about this forum... I am an avid owner of many different F-Series trucks over the years from an '81 to '06 in various configurations. I am seriously in need of some direction from y'all on this '91 I am buying. None of the interior or exterior lights work, neither does the radio. The blower fan works though, so the cab isn't totally void of power. Where do I start? Should I pay someone to diag and fix??? Direction... Please?
Simple stuff, check the bulbs easiest to get to just to make sure none are blown. Check ALL fuses and relays in both the cab panel and the under hood distribution box.
Forge-World-FORD is offline   Reply With Quote
Old 11-20-2013, 09:14 PM   #3
November 2011 TOTM Winner
 
5Rangers's Avatar
 
Join Date: Apr 2011
Location: Dallas area
Posts: 1,438
Mentioned: 0 Post(s)
Thanks: 14
Thanked 72 Times in 70 Posts
Feedback Score: 0 reviews
Default

Besides what Forge said you my also want to consider checking the fusible links coming off the hot side of the starter relay.
__________________
November 2011 TOTM Winner, 88 1/2 ton swb 4.9 4spd man 4wd 3.55 gears, Rear Aussie Locker,Pro Gold 11" Luk clutch, 4" Rancho Lift, 2" body lift, 35" Maxxis Bighorns on Ultra Wheels, Rocksolid front Winch Bumper, 10k Engo Winch, 2.5 exhaust, Magnaflow muffler, 38 gallon Spectra rear tank, Bushwacker Flares, Warn premium hubs, FSB Transfer case skidplate, Knuckle under mod, 3G 160a Alternator mod.
5Rangers is offline   Reply With Quote
Old 11-21-2013, 08:41 AM   #4
Junior Member
 
Join Date: Nov 2013
Posts: 5
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Thanks for the input. The kid I'm getting it from said the problem started shortly after he was messing with the aftermarket radio. There was a spark from the wire that runs to the cigarette lighter. Just wasn't sure what all ran off the circuit that controls the headlights, and if the interior lights were on the same ciruit/relay.
okieiniowa78 is offline   Reply With Quote
Old 11-21-2013, 09:21 AM   #5
November 2011 TOTM Winner
 
5Rangers's Avatar
 
Join Date: Apr 2011
Location: Dallas area
Posts: 1,438
Mentioned: 0 Post(s)
Thanks: 14
Thanked 72 Times in 70 Posts
Feedback Score: 0 reviews
Default

Which lights specifically don't work?
Headlights, running lights, turn signal lights, brake lights, emergency flashers, instrument cluster lights, overhead dome light.

If we know that specific information we might be able to nail it down to one component.

Ford runs different lights off different circuits. I could be all day posting pictures and explaining.
__________________
November 2011 TOTM Winner, 88 1/2 ton swb 4.9 4spd man 4wd 3.55 gears, Rear Aussie Locker,Pro Gold 11" Luk clutch, 4" Rancho Lift, 2" body lift, 35" Maxxis Bighorns on Ultra Wheels, Rocksolid front Winch Bumper, 10k Engo Winch, 2.5 exhaust, Magnaflow muffler, 38 gallon Spectra rear tank, Bushwacker Flares, Warn premium hubs, FSB Transfer case skidplate, Knuckle under mod, 3G 160a Alternator mod.
5Rangers is offline   Reply With Quote
Old 11-22-2013, 02:29 PM   #6
Junior Member
 
Join Date: Nov 2013
Posts: 5
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

The headlights, taillights, dash lights, radio, dome light are all dead. The turn signal and brake lights work fine.
Thank You for trying to narrow this down.
okieiniowa78 is offline   Reply With Quote
Old 11-23-2013, 10:49 AM   #7
November 2011 TOTM Winner
 
5Rangers's Avatar
 
Join Date: Apr 2011
Location: Dallas area
Posts: 1,438
Mentioned: 0 Post(s)
Thanks: 14
Thanked 72 Times in 70 Posts
Feedback Score: 0 reviews
Default

Headlights are powered by fuselink L, Exterior lights/ fuse 4, courtesy lamps/fuse 8, also fuselink L, cluster illumination/ fuses 10 & 11, and radio/ fuse 11 powered by fuselink M. If M was open there would be a lot of other things not working. The only thing in common to all of these is the main light switch.

I'm confused a little bit because not only your rear park but also your front park lights should be out and you specified tail lights only.

Also, turn/stop and hazard lamps don't go through the light switch which would explain why they are working.

Here are testing procedures:
Click the image to open in full size.
__________________
November 2011 TOTM Winner, 88 1/2 ton swb 4.9 4spd man 4wd 3.55 gears, Rear Aussie Locker,Pro Gold 11" Luk clutch, 4" Rancho Lift, 2" body lift, 35" Maxxis Bighorns on Ultra Wheels, Rocksolid front Winch Bumper, 10k Engo Winch, 2.5 exhaust, Magnaflow muffler, 38 gallon Spectra rear tank, Bushwacker Flares, Warn premium hubs, FSB Transfer case skidplate, Knuckle under mod, 3G 160a Alternator mod.

Last edited by 5Rangers; 11-23-2013 at 11:09 AM.
5Rangers is offline   Reply With Quote
Old 11-23-2013, 05:31 PM   #8
Junior Member
 
Join Date: Sep 2011
Posts: 7
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I'm having similar problems. As well as the dash lights, my turn signals have recently stopped working. I've checked all the fuses, replaced the signal flasher AND even replaced the signal switch (that was a pain in the &$!. Any ideas? Do you have a similar testing chart for the turn signals?
donpagel is offline   Reply With Quote
Old 11-24-2013, 01:24 PM   #9
Junior Member
 
Join Date: Nov 2013
Posts: 5
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Just the brake lights and turn signals work. No parking lamps work, no headlights. Dash and dome are dead. No power to the radio either.
From what I'm gathering from your reply is the headlight switch may be to blame here?
okieiniowa78 is offline   Reply With Quote
Old 11-24-2013, 01:32 PM   #10
November 2011 TOTM Winner
 
5Rangers's Avatar
 
Join Date: Apr 2011
Location: Dallas area
Posts: 1,438
Mentioned: 0 Post(s)
Thanks: 14
Thanked 72 Times in 70 Posts
Feedback Score: 0 reviews
Default

Yes.. main light switch.. you can ring it out with a meter to make sure..
__________________
November 2011 TOTM Winner, 88 1/2 ton swb 4.9 4spd man 4wd 3.55 gears, Rear Aussie Locker,Pro Gold 11" Luk clutch, 4" Rancho Lift, 2" body lift, 35" Maxxis Bighorns on Ultra Wheels, Rocksolid front Winch Bumper, 10k Engo Winch, 2.5 exhaust, Magnaflow muffler, 38 gallon Spectra rear tank, Bushwacker Flares, Warn premium hubs, FSB Transfer case skidplate, Knuckle under mod, 3G 160a Alternator mod.
5Rangers is offline   Reply With Quote
Old 11-24-2013, 01:32 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 02:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.