Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > 1987 - 1996 F150 > Electrical
Sign in using an external account
Register Forgot Password?


Welcome to F150 Forum!
Welcome to F150 Forum,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 06-17-2014, 10:35 PM   #1
Junior Member
 
Join Date: Jun 2014
Location: Northeast Arkansas
Posts: 7
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Cruise Control

Hello all.
I am having problems with my cruise control. When I purchased the truck (1990 f150 xlt lariat 2wd) the cruise control worked fine. The other day I started to use it and it will not work. Fuse is not popped. Any ideas? Thanks in advance.
old_blue_302 is offline   Reply With Quote
Old 06-23-2014, 07:31 AM   #2
Junior Member
 
Join Date: Apr 2014
Location: Los Angeles
Posts: 11
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Is the horn out too? It might be the clock spring wiring under the air bag
olddog45 is offline   Reply With Quote
Old 06-23-2014, 11:22 PM   #3
Member
 
Join Date: Jun 2014
Posts: 59
Mentioned: 0 Post(s)
Thanks: 2
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Default

Is your airbag light blinking?
VickMacky is online now   Reply With Quote
Old 07-01-2014, 06:46 PM   #4
Junior Member
 
Join Date: Jun 2014
Location: Northeast Arkansas
Posts: 7
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by olddog45 View Post
Is the horn out too? It might be the clock spring wiring under the air bag


no the horn works fine. it started working again the other day and worked for 2 days and then stopped working again. I haven't had the chance to get back out there and look at it though.
old_blue_302 is offline   Reply With Quote
Old 07-01-2014, 06:48 PM   #5
Junior Member
 
Join Date: Jun 2014
Location: Northeast Arkansas
Posts: 7
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by VickMacky View Post
Is your airbag light blinking?


no the airbag light isn't on. I have looked for lights to be on every time I start the truck but none ever come on. its very puzzling. lol
old_blue_302 is offline   Reply With Quote
Old 07-01-2014, 06:48 PM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


 

The Mustang Source
All times are GMT -4. The time now is 07:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SEO by vBSEO 3.5.2
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.