Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > 1987 - 1996 F150 > Electrical
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 06-26-2014, 11:50 AM   #1
Junior Member
 
Join Date: May 2014
Posts: 4
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 89 f150 wont start

My truck turns over really fast then after about 8 rotation it just stops like the battery is dead.. also been melting battery positive cable and starter cable... burned up 3 starters. 7 soli nodes , 4 battery cables. I'm at my end on this truck... it's a 1989 f150 with 4.9 and 5 speed.. any information would help. ... also it's not ground issue. Have three grounds , one on engine, frame and body.
johnpaulmelone is offline   Reply With Quote
Old 06-26-2014, 11:50 AM
 
 
 
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 08:11 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.