Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > 1987 - 1996 F150 > Interior
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 04-30-2014, 07:23 PM   #31
lost my Car again...
 
TheCollector's Avatar
 
Join Date: Jun 2010
Location: Auburn Maine
Posts: 6,289
Mentioned: 0 Post(s)
Thanks: 59
Thanked 34 Times in 34 Posts
Feedback Score: 0 reviews
Default

Sometimes its just a loose connection haha the electrics are over 15 years old Plus haha
__________________
you can fix anything with enough hard work determination and a 5 lb sledge

TheCollector is offline   Reply With Quote
Old 05-01-2014, 05:45 PM   #32
Junior Member
 
MikeGreensides's Avatar
 
Join Date: Nov 2012
Location: Grimsby, Canada Ontario
Posts: 20
Mentioned: 0 Post(s)
Thanks: 1
Thanked 4 Times in 3 Posts
Feedback Score: 0 reviews
Default

True enough lol, I'm sure I can get it figured out just figured if someone else has has this problem it would save me some time hahaha cause I'm sure I'm not alone when I say I HATE chasing wires/bulbs lol
MikeGreensides is offline   Reply With Quote
Old 05-01-2014, 06:12 PM   #33
lost my Car again...
 
TheCollector's Avatar
 
Join Date: Jun 2010
Location: Auburn Maine
Posts: 6,289
Mentioned: 0 Post(s)
Thanks: 59
Thanked 34 Times in 34 Posts
Feedback Score: 0 reviews
Default

Haha yeah. I'm currently chasing wires for my fuel gauge... I should add that LEDs are polarized as in only works one way. So if the led does not light up, switch it around. But it sounds like you got a different issue.
__________________
you can fix anything with enough hard work determination and a 5 lb sledge

TheCollector is offline   Reply With Quote
Old 05-01-2014, 06:12 PM
 
 
 
Reply

Tags
bulbs, gauge, gauge cluster, led, led bulbs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 07:38 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.