Crate motor issues - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Pre-1997 F150 > Engine Talk > 8 Cylinder Engines
Log In 


Crate motor issues

Reply
 
 
 
 
Thread Tools Search this Thread
Old 05-27-2014, 10:15 PM   #1
Gone Like Yesterday
5 Year Member
 
95F150 2FST4U's Avatar
 
Join Date: Oct 2008
Location: Canton, GA
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default Crate motor issues

See photo. I didn't feel like retyping.
Attached Thumbnails
Crate motor issues-image-4071341442.jpg  
__________________
~K.E.G.
95F150 2FST4U is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 05-28-2014, 01:41 AM   #2
Senior Member
 
Forge-World-FORD's Avatar
 
Join Date: Jun 2011
Posts: 2,364
Thanks: 0
Thanked 101 Times in 98 Posts
Feedback Score: 0 reviews
Default

Then just copy and paste it.
Forge-World-FORD is offline   Reply With Quote
Old 05-28-2014, 03:08 PM   #3
Gone Like Yesterday
5 Year Member
 
95F150 2FST4U's Avatar
 
Join Date: Oct 2008
Location: Canton, GA
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by Forge-World-FORD View Post
Then just copy and paste it.
I tried. Won't let me.
__________________
~K.E.G.
95F150 2FST4U is offline   Reply With Quote
Old 06-06-2014, 01:02 AM   #4
Martin
 
Join Date: Jan 2011
Location: Lehi, Utah
Posts: 1,795
Thanked 104 Times in 83 Posts
Feedback Score: 0 reviews
Default

Was a member not long ago with similar situation but has a 90 or so truck with an HO firing order 302. His just required wire re route.

The injectors fire sequentially on the 95 302, so they need to match spark firing order. I think your only solution is to modify the injector wiring harness to match the non HO firing order. Did you use the damper from the 95? I believe that is different on fuel injection vs carb.
sdmartin65 is offline   Reply With Quote
Old 06-08-2014, 03:12 PM   #5
Gone Like Yesterday
5 Year Member
 
95F150 2FST4U's Avatar
 
Join Date: Oct 2008
Location: Canton, GA
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by sdmartin65 View Post
Was a member not long ago with similar situation but has a 90 or so truck with an HO firing order 302. His just required wire re route. The injectors fire sequentially on the 95 302, so they need to match spark firing order. I think your only solution is to modify the injector wiring harness to match the non HO firing order. Did you use the damper from the 95? I believe that is different on fuel injection vs carb.
I tried searching for that thread but found nothing. But an update: We are getting power (12v) to all the injectors however number 1,2,6,8 around not getting a ground pulse where as the others are. I've checked the under hood fuses. Is there a ground I possibly missed when putting the motor in? That's the only thing I can think of.
__________________
~K.E.G.
95F150 2FST4U is offline   Reply With Quote
Old 06-17-2014, 05:13 PM   #6
Gone Like Yesterday
5 Year Member
 
95F150 2FST4U's Avatar
 
Join Date: Oct 2008
Location: Canton, GA
Posts: 40
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Turned out to be defective distributor module located on driver side fender well. Purs like a kitten
__________________
~K.E.G.
95F150 2FST4U is offline   Reply With Quote
Old 06-17-2014, 05:13 PM
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 12:50 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.