Go Back   Ford F150 Forum - Community of Ford Truck Fans > Ford F150 Forums > Aftermarket Products, Reviews & Installation > Lighting
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 01-26-2014, 07:14 AM   #1
Senior Member
 
Join Date: Aug 2012
Posts: 516
Mentioned: 2 Post(s)
Thanked 70 Times in 38 Posts
Feedback Score: 0 reviews
Default HIDs and your radio

Does The ballasts emit a frequency that impairs FM reception.
_________
http://www.f150forum.com/f38/bad-rad...-ideas-244109/
__________________
2012 F150 ECO SC 157" PLATINUM
fcancer is offline   Reply With Quote
Old 01-26-2014, 10:18 AM   #2
Senior Member
 
Join Date: Aug 2012
Posts: 516
Mentioned: 2 Post(s)
Thanked 70 Times in 38 Posts
Feedback Score: 0 reviews
Default

Problem sloved,,,
yes it does
__________________
2012 F150 ECO SC 157" PLATINUM
fcancer is offline   Reply With Quote
Old 01-26-2014, 10:22 AM   #3
MGD
Digital Immigrant
 
Join Date: Jan 2014
Posts: 1,221
Mentioned: 9 Post(s)
Thanked 251 Times in 199 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by fcancer View Post
Problem sloved,,,
yes it does
The cheap crappola Chinglish PnP one do ( e.g DDM, etc)

The high quality units typically found from a good retrofit supplier do not. Neither do the OEM ballasts ( e.g. Denso).

MGD
MGD is offline   Reply With Quote
Old 01-26-2014, 03:39 PM   #4
Senior Member
 
Join Date: Aug 2012
Posts: 516
Mentioned: 2 Post(s)
Thanked 70 Times in 38 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by MGD View Post
The cheap crappola Chinglish PnP one do ( e.g DDM, etc)

The high quality units typically found from a good retrofit supplier do not. Neither do the OEM ballasts ( e.g. Denso).

MGD
Morimoto 5Five HO ballasts ,,,SVS bulbs from TRS

Lights on = no reception
lights off=crystal clear
Is there a fix for this
__________________
2012 F150 ECO SC 157" PLATINUM
fcancer is offline   Reply With Quote
Old 01-26-2014, 05:20 PM   #5
MGD
Digital Immigrant
 
Join Date: Jan 2014
Posts: 1,221
Mentioned: 9 Post(s)
Thanked 251 Times in 199 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by fcancer View Post
Morimoto 5Five HO ballasts ,,,SVS bulbs from TRS

Lights on = no reception
lights off=crystal clear
Is there a fix for this
Hi.

You bet.

You have a faulty ballast. Isolate which one ( by disconnecting one at a time ).

Contact TRS for a replacement.

Other possible causes - bad harness, poor grounding.

Good luck!

MGD
MGD is offline   Reply With Quote
Old 01-28-2014, 07:31 AM   #6
Senior Member
 
Join Date: Aug 2012
Posts: 516
Mentioned: 2 Post(s)
Thanked 70 Times in 38 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by MGD View Post
Hi.

You bet.

You have a faulty ballast. Isolate which one ( by disconnecting one at a time ).

Contact TRS for a replacement.

Other possible causes - bad harness, poor grounding.

Good luck!

MGD
disconnected each and didn't notice any difference
grounding is good
don't know how to check for a bad harness?
Ill call TRS today to see what they have to say
__________________
2012 F150 ECO SC 157" PLATINUM
fcancer is offline   Reply With Quote
Old 01-28-2014, 10:06 AM   #7
Senior Member
 
Azuri's Avatar
 
Join Date: Apr 2013
Location: Ontario, Canada
Posts: 1,819
Mentioned: 36 Post(s)
Thanked 464 Times in 321 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by fcancer View Post
disconnected each and didn't notice any difference
grounding is good
don't know how to check for a bad harness?
Ill call TRS today to see what they have to say
I have 5Five ballasts previously SS and now DSP ballasts and have no interferance on both AM or FM frequency I suggest checking out HIDplanet forums too. I've seen a few reports of this issue so they may have the answered it over there. As you said TRS should be able to isolate the issue too.
__________________
Mods / Accessories: Luxury Package OEM Floor Mats LINE X Bakflip VP Tonneu Borla "ATAK" Exhaust Llumar CTX 20% Tint LED Lighting Int AVS Vent Shades Tailgate Assist Bilstein 5100 Shocks Retrofitted LED Fogs Clazzio Custom Seat Covers Amber Reflectors Swapped To Black Remote Starter bilinvic Retrofits HIDs
Azuri is offline   Reply With Quote
Old 01-28-2014, 10:32 AM   #8
Senior Member
 
Join Date: Nov 2013
Location: Euless, Tx
Posts: 574
Mentioned: 3 Post(s)
Thanked 55 Times in 46 Posts
Feedback Score: 0 reviews
Default

fcancer - Did you disconnect the light or the ballast? You must disconnect the ballast from your truck wiring.
__________________
2011 F150 4X4, 5.0, Scab, Lbed, HD Payload Package, Blue Flame Metallic, ARE Shell, Kappa 602.11cfX4, Dually reverse lights, Dually high beams, DD3, Kenwood DNX890 with Maestro, NVX MVPA4 and MVPA1, JL Audio 10TW3 subwooofer in custom cabinet, Billnvic HIDs, RCI Metalworks skidplates.
Feathermerchant is offline   Reply With Quote
Old 01-29-2014, 03:30 PM   #9
Senior Member
 
Join Date: Aug 2012
Posts: 516
Mentioned: 2 Post(s)
Thanked 70 Times in 38 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by Feathermerchant View Post
fcancer - Did you disconnect the light or the ballast? You must disconnect the ballast from your truck wiring.
ballast
I did talk to TRS and they said
either the wiring harness is to close to the antenna( I can't see that being the case ,because we all have it in the same spot )
or
move the ground to a different spot.
I'll give that a shot
__________________
2012 F150 ECO SC 157" PLATINUM
fcancer is offline   Reply With Quote
Old 01-30-2014, 01:05 PM   #10
Senior Member
 
benchwarmer4203's Avatar
 
Join Date: Jan 2013
Location: Morgantown, WV
Posts: 546
Mentioned: 0 Post(s)
Thanked 76 Times in 72 Posts
Feedback Score: 0 reviews
Default

Did you tie into a factory ground or make your own?
__________________

2011 SCrew XLT
benchwarmer4203 is offline   Reply With Quote
Old 01-30-2014, 01:05 PM
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 02:25 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.