hitch problems - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Ford F150 Forums > Towing/ Hauling/ Plowing
Log In 


hitch problems

Reply
 
 
 
 
Thread Tools Search this Thread
Old 07-11-2014, 11:42 PM   #1
Junior Member
 
Join Date: Jul 2014
Location: canada
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default hitch problems

New to this forum. I am having problems with no power going to the 7 pin trailer connector. When I hooked up the trailer there was no signal lights no brake lights. I checked the plug with an automotive test light and there is not power for the signals and brakes. I installed the relay that was given with the truck so that 12v will be available at the 7 pin connector. I tested the pin and there is 12v present. I thought it may be the wiring harness but with the 12v present I am not sure that it is the harness. Any idea about this problem?
storkfrom70s is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 07-11-2014, 11:48 PM   #2
Senior Member
 
Z7What's Avatar
 
Join Date: Apr 2013
Posts: 4,333
Thanked 449 Times in 399 Posts
Feedback Score: 0 reviews
Default

The relay only provides, charging if the trailers batteries not power to the plug. Just a FYI.

But for starters is start checking fuses.

Wayne
__________________
Silver 2013 F-150 Supercrew 5.0L FX2
Boss Coilover Suspension - Nitto Terra Grapplers - Airaid Jr Intake - Banks Monster Exhaust - MagHytec Rearend Cover - AMP Steps - Stiffler Traction Bars - SCT Tuned By Torrie @ Unleashed Tuning
Built On 11-15-2012
Z7What is offline   Reply With Quote
Old 07-12-2014, 05:26 PM   #3
Senior Member
 
blueovelboy's Avatar
 
Join Date: Oct 2010
Location: bay area
Posts: 1,975
Thanked 60 Times in 54 Posts
Feedback Score: 0 reviews
Default

fuse #9 relay#21 on 09 to 14 f150s look at them if there good take it in you might have to drop rear tire and see if you have a bad connection at the rear harness block connector
__________________
2012 screw 4x4 XLT 5.0!
( o )( o )
blueovelboy is offline   Reply With Quote
Old 07-12-2014, 05:26 PM
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 10:27 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.