Go Back   Ford F150 Forum - Community of Ford Truck Fans > Ford F150 Forums > Towing/ Hauling/ Plowing
Sign in using an external account
Register Forgot Password?


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 07-12-2014, 12:42 AM   #1
Junior Member
 
Join Date: Jul 2014
Location: canada
Posts: 1
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default hitch problems

New to this forum. I am having problems with no power going to the 7 pin trailer connector. When I hooked up the trailer there was no signal lights no brake lights. I checked the plug with an automotive test light and there is not power for the signals and brakes. I installed the relay that was given with the truck so that 12v will be available at the 7 pin connector. I tested the pin and there is 12v present. I thought it may be the wiring harness but with the 12v present I am not sure that it is the harness. Any idea about this problem?
storkfrom70s is offline   Reply With Quote
Old 07-12-2014, 12:48 AM   #2
Senior Member
 
Z7What's Avatar
 
Join Date: Apr 2013
Posts: 3,144
Mentioned: 19 Post(s)
Thanked 307 Times in 273 Posts
Feedback Score: 0 reviews
Default

The relay only provides, charging if the trailers batteries not power to the plug. Just a FYI.

But for starters is start checking fuses.

Wayne
__________________
Silver 2013 F-150 5.0L FX2 - Leveled/Lifted-275/60R20 Nitto Terra Grapplers-Airaid Jr Intake-Resonator Delete-SCT Tuned By Torrie @ Unleashed Tuning
Built On 11-15-2012
Z7What is online now   Reply With Quote
Old 07-12-2014, 06:26 PM   #3
Senior Member
 
blueovelboy's Avatar
 
Join Date: Oct 2010
Location: bay area
Posts: 1,911
Mentioned: 8 Post(s)
Thanked 54 Times in 49 Posts
Feedback Score: 0 reviews
Default

fuse #9 relay#21 on 09 to 14 f150s look at them if there good take it in you might have to drop rear tire and see if you have a bad connection at the rear harness block connector
__________________
2012 screw 4x4 XLT 5.0!
( o )( o )
blueovelboy is offline   Reply With Quote
Old 07-12-2014, 06:26 PM
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source
All times are GMT -4. The time now is 12:26 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.