Ford F150 Forum - Community of Ford Truck Fans

Ford F150 Forum - Community of Ford Truck Fans (http://www.f150forum.com/)
-   Members Builds (http://www.f150forum.com/f78/)
-   -   2010 Lariat (http://www.f150forum.com/f78/2010-lariat-249401/)

matt_m 03-02-2014 09:53 PM

2010 Lariat
 
6 Attachment(s)
Spent the weekend installing a round of mods on my new-to-me 2010 Lariat 4x4 after getting a bunch of advise here.

A few weeks ago I installed an Aries bull bar and Piaa 520 driving lights.
Attachment 296775

This weekend I also installed some LED bed lighting. I used waterproof LED tape. I wouldn't buy the stuff I did again as the adhesive was terrible despite being "3M". I ended up using some 3M body molding adhesive.

Attachment 296778

The switches are installed in the coin tray in the center console.

Attachment 296779

I also transferred the Bakflip cover from my previous truck to this one.

Attachment 296793

And I transferred my ProClip phone mount from the old truck and added a handy hook to keep the phone cord out of the salt water that's collected in the Husky Liner mats (kinda hard on iPhone cords!)

Attachment 296796

And I picked up a factory chrome exhaust tip off eBay.

Attachment 296795

matt_m 03-02-2014 09:57 PM

3 Attachment(s)
The big project this weekend was an audio upgrade. Really happy with the way this turned out. Unfortunately I didn't stop to take any pictures of all the hidden parts.

Overall I'm pretty happy with the Maestro/Kenwood combo. The only minor negatives are a fairly long delay between pressing the voice button and hearing the Sync prompts and the fairly long "boot" time for the radio when the truck turns on.

Attachment 296797

Attachment 296798

Attachment 296799

Cordude64 03-03-2014 02:48 AM

Clean, nice and unique. Good job.

KevFord1993 03-03-2014 04:02 AM

Looking good, I like the color white on these trucks too

Carabidae 03-03-2014 05:44 AM

nice truck!
love what u did so far, i got the audio parts almost ready for install just waiting for the SWC.
For the heavy boot of the HU, i think i read on kenwood forums that the issue was resolved with the last update. as for the swc module delay, im not sure, maybe vendors can help.

matt_m 03-03-2014 09:26 AM

1 Attachment(s)
Thanks. I like the white too but wanted a little color so I replaced the factory 4x4 decals with these. I might do the logos on the fenders and tailgates too either red or white.

Attachment 296901

It doesn't look like Kenwood offers any firmware update for this unit, at least currently.

One thing I forgot to mention is that I was able to use Kenwood's USB port in place of the Sync USB port. I had to trim a little plastic off the front of the Kenwood port (flush with the metal) and then used two small screws to clamp it into the housing on the back side of the sync faceplate. The screw holes won't interfere with putting sync back in place in the future if needed.

RedStx13 03-03-2014 12:20 PM

Lookin good!

12V Guy 03-03-2014 02:33 PM

Quote:

Originally Posted by matt_m (Post 3337603)
The only minor negatives are a fairly long delay between pressing the voice button and hearing the Sync prompts.


Hi,


The delay should only exist when you are not in a Sync Media source when you press the voice button. In that case, we have to first switch the radio to the last used Sync source and then tell Sync to talk. If you already using Sync (for streaming or USB) then the response to pressing voice should be very quick.


Also, if you press and hold the voice button, you should get a Sync Phone voice prompt very quickly.


Cheers,


Mark

matt_m 03-04-2014 12:33 AM

Good to know! I'll pretty much only be using sync for phone.

matt_m 03-12-2014 11:45 PM

1 Attachment(s)
The original wheels have quite a bit of corrosion under the clear coat. Seems to be a common problem around here. I found a set of chrome clad wheels on Craigslist and was able to get them pretty cheap as they were caked in brake dust and had a couple very small dings. They cleaned up nicely with about an hour's work. I've got a set of lug nuts and new TPMS's (figured for the price I'll just have a new set on the new wheels) on the way and hopefully I can take it in to get the tires swapped sometime next week.


All times are GMT -4. The time now is 01:57 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2006 - 20011 F150forum.com