Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2009 - 2014 Ford F150 > 2011+ Engine Related Questions
Sign in using an external account
Register Forgot Password?

MAJOR Ecoboost Acceleration PROBLEMS-URGENT code P2112

Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 12-29-2014, 09:47 AM   #1
Junior Member
 
Join Date: Feb 2013
Posts: 16
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default MAJOR Ecoboost Acceleration PROBLEMS-URGENT code P2112

2013 F150 ecoboost power loss, engine shudder, CEL, wrench
Looking for help ASAP

About a month ago I had very similar symptoms to some other posts but I don't think anyone hit on my specific problem.

Truck info-
2013 F150 supercrew 3.5L ecoboost 4x4 XLT with the 3.55 rear end
about 70,000 miles total- mostly highway, about 20k miles towing
I have the ESP warranty to 125,000 miles? +/-

In November, I stopped at walmart to buy oil for a weekend oil change.
Truck restarted hard.
VERY rough idle, service engine "wrench" light, CEL came on - truck could barely stay running.
We towed on my flatbed to the dealer- after several days & lots of tests, they found a bunch of CEL relating to the turbo, throttle, etc (I don't have the slip with me)
Result- they replaced throttle body & reset codes.
Truck seemed fine.
$100 deductible on ESP

December, maybe 10,000 miles since last service in November +/- (lots of highway road trips)
I'm on a cross-country road trip NY- Cali with a little airstream trailer, 18ft 3500lb trailer.
Truck dies on US interstate 80 near Chicago on a Sunday afternoon.
Similar problems-
Power loss, CEL, service engine "wrench" light

NEED HELP ASAP -
I'm missing out on Christmas with my family because they can't fix it.

Day 1
Dealership reset codes, did a PCM reprogram, charged $170
Hooked up, drove off- same problem as soon as I got to highway ramp
No CEL lights, but "wrench" light came on and I lost power.
Truck re-starts & drives fine back to dealership

Day 2
Dealership called the hotline, continuity tested and load tested the harnesses from computer to the throttle body- checked & replaced some chips, wires, wire harness. Road tested without trailer about 50 miles. Seemed ok. Truck seemed fine.
$100 deductible on ESP
Hooked up, drove off- same problem about 1-2 miles from the dealer - I didn't even get to the highway.
No CEL lights, but "wrench" light came on and I lost power.
Truck re-starts & drives fine back to the dealer.

NEED HELP!!
Day 3 - dealer is closed for Christmas Eve & Christmas.
I drove another 10-20 miles around empty to try and reproduce the problem- no CEL, no "wrench" lights
Dealer asks me to check back after Christmas.
Dealer closes- I get 3 consecutive "wrench" MIL and a CEL with code P2112 that evening.
Now I'm stuck in Indiana for at least 2-3 days over Christmas

Day 4, Christmas Eve-
I pulled the engine cover off and googled a "how to change ecoboost spark plugs" from the parking lot of an auto zone.

Went pretty smooth - I did it in the autozone lot as I was looking for immediate feedback about my loss of power situation in about 45 minutes as it's going to snow 3-6 inches tomorrow.

6 new plugs with a 0.030 gap.
never seize on the threads.
di-electric grease on the connection.
Drove out of the lot and had a "wrench" service engine light within 1/4 mile.

Day 5-
Dealer can't replicate MIL or P2112 codes even after driving.
I can't replicate issues.
I leave at 10am and successfully make it 700 miles to Lincoln Nebraska

Day 6
Start at 7am in light snow, very cold (7 degrees F).
Drive about 350 miles across Nebraska-
Same problems all over again- "wrench" MIL, CEL P2112, truck loses power, stalls on highway.
I limp into Ogallala NE - ford mechanic pulls P2112 code.
Checks it on his laptop, clears the code.
We go for a quick shakedown ride to replicate- it's not a "hard fault" and doesn't stay locked in/ and re-enable at restart.
Truck throws a new code within 1000 feet out the dealer lot.

Now I'm stuck waiting over a weekend at a very small-town dealer who barely has mechanics to service his own customers- let alone my month long issues.

NEED HELP!!
I have a Mechanical Engineering degree and not real thrilled about the "check/ change" component poke & hope fixes- seems good then fails.

Has anyone else had a similar problem?
Any other leads for them to check out?

I have some thoughts that it could be a bad throttle body again (this one is nearly new- only 10k miles- 50/50 hwy and towing) throttle position sensor, wiring, connection or similar. Maybe even bad fuel or fuel filter.

I aslo welcome any advice from Ford Engineers or Techs who may be familiar or can give specific advice
Thanks
92497pmu is offline   Reply With Quote
Old 12-29-2014, 10:02 AM   #2
Junior Member
 
Join Date: May 2013
Posts: 18
Mentioned: 0 Post(s)
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

I had the same issue in a friend's F150. Replacing the throttle body fixed it.
awddsm97 is offline   Reply With Quote
Old 12-29-2014, 05:57 PM   #3
Junior Member
 
Join Date: Feb 2013
Posts: 16
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

new update.
New computer/ PCM.
Should be here tomorrow morning.
Let's see how this goes.
92497pmu is offline   Reply With Quote
Old 12-30-2014, 09:10 AM   #4
Senior Member
 
Join Date: Jul 2011
Location: midwest
Posts: 1,711
Mentioned: 0 Post(s)
Thanked 188 Times in 145 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by 92497pmu View Post
new update.
New computer/ PCM.
Should be here tomorrow morning.
Let's see how this goes.
I'll keep my fingers crossed for you.
__________________
2001 f150 screw 4wd 5.4. Xlt -sold
2004 f150 screw 4wd 5.4. Xlt -sold
2011 f150 screw 4wd ecoboost lariat -sold
2013 f150 screw 4wd ecoboost 157" lariat - current
zx12-iowa is offline   Reply With Quote
Old 12-30-2014, 02:32 PM   #5
Opinionated Blowhard
 
Join Date: Oct 2011
Location: Knoxville, TN
Posts: 818
Mentioned: 0 Post(s)
Thanked 128 Times in 74 Posts
Feedback Score: 0 reviews
Default

Check all wiring associated with turbos and boost control module. Low voltage will trigger code, wrench, and cel. Good luck.
__________________
2014 EB SCREW XLT 4X4 5.5 bed Heavy Duty Tow Pkg, Peragon sliding bed cover, 3.73 E-Locker, Bone Stock, Sunset.
Kenferg1 is offline   Reply With Quote
Old 12-30-2014, 03:55 PM   #6
Ford Customer Service

 
FordService's Avatar
 
Join Date: Oct 2010
Location: Dearborn, MI
Posts: 2,392
Mentioned: 32 Post(s)
Thanked 461 Times in 310 Posts
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by 92497pmu View Post
2013 F150 ecoboost power loss, engine shudder, CEL, wrench
Looking for help ASAP

About a month ago I had very similar symptoms to some other posts but I don't think anyone hit on my specific problem.

Truck info-
2013 F150 supercrew 3.5L ecoboost 4x4 XLT with the 3.55 rear end
about 70,000 miles total- mostly highway, about 20k miles towing
I have the ESP warranty to 125,000 miles? +/-

In November, I stopped at walmart to buy oil for a weekend oil change.
Truck restarted hard.
VERY rough idle, service engine "wrench" light, CEL came on - truck could barely stay running.
We towed on my flatbed to the dealer- after several days & lots of tests, they found a bunch of CEL relating to the turbo, throttle, etc (I don't have the slip with me)
Result- they replaced throttle body & reset codes.
Truck seemed fine.
$100 deductible on ESP

December, maybe 10,000 miles since last service in November +/- (lots of highway road trips)
I'm on a cross-country road trip NY- Cali with a little airstream trailer, 18ft 3500lb trailer.
Truck dies on US interstate 80 near Chicago on a Sunday afternoon.
Similar problems-
Power loss, CEL, service engine "wrench" light

NEED HELP ASAP -
I'm missing out on Christmas with my family because they can't fix it.

Day 1
Dealership reset codes, did a PCM reprogram, charged $170
Hooked up, drove off- same problem as soon as I got to highway ramp
No CEL lights, but "wrench" light came on and I lost power.
Truck re-starts & drives fine back to dealership

Day 2
Dealership called the hotline, continuity tested and load tested the harnesses from computer to the throttle body- checked & replaced some chips, wires, wire harness. Road tested without trailer about 50 miles. Seemed ok. Truck seemed fine.
$100 deductible on ESP
Hooked up, drove off- same problem about 1-2 miles from the dealer - I didn't even get to the highway.
No CEL lights, but "wrench" light came on and I lost power.
Truck re-starts & drives fine back to the dealer.

NEED HELP!!
Day 3 - dealer is closed for Christmas Eve & Christmas.
I drove another 10-20 miles around empty to try and reproduce the problem- no CEL, no "wrench" lights
Dealer asks me to check back after Christmas.
Dealer closes- I get 3 consecutive "wrench" MIL and a CEL with code P2112 that evening.
Now I'm stuck in Indiana for at least 2-3 days over Christmas

Day 4, Christmas Eve-
I pulled the engine cover off and googled a "how to change ecoboost spark plugs" from the parking lot of an auto zone.

Went pretty smooth - I did it in the autozone lot as I was looking for immediate feedback about my loss of power situation in about 45 minutes as it's going to snow 3-6 inches tomorrow.

6 new plugs with a 0.030 gap.
never seize on the threads.
di-electric grease on the connection.
Drove out of the lot and had a "wrench" service engine light within 1/4 mile.

Day 5-
Dealer can't replicate MIL or P2112 codes even after driving.
I can't replicate issues.
I leave at 10am and successfully make it 700 miles to Lincoln Nebraska

Day 6
Start at 7am in light snow, very cold (7 degrees F).
Drive about 350 miles across Nebraska-
Same problems all over again- "wrench" MIL, CEL P2112, truck loses power, stalls on highway.
I limp into Ogallala NE - ford mechanic pulls P2112 code.
Checks it on his laptop, clears the code.
We go for a quick shakedown ride to replicate- it's not a "hard fault" and doesn't stay locked in/ and re-enable at restart.
Truck throws a new code within 1000 feet out the dealer lot.

Now I'm stuck waiting over a weekend at a very small-town dealer who barely has mechanics to service his own customers- let alone my month long issues.

NEED HELP!!
I have a Mechanical Engineering degree and not real thrilled about the "check/ change" component poke & hope fixes- seems good then fails.

Has anyone else had a similar problem?
Any other leads for them to check out?

I have some thoughts that it could be a bad throttle body again (this one is nearly new- only 10k miles- 50/50 hwy and towing) throttle position sensor, wiring, connection or similar. Maybe even bad fuel or fuel filter.

I aslo welcome any advice from Ford Engineers or Techs who may be familiar or can give specific advice
Thanks
Thank you for reaching out on the forum about this, 92497pmu. I'll escalate this to the regional customer service manager right away! They'll work with your dealership to reach the best resolution. Please send me a private message with your full name, VIN, servicing dealership, and best daytime contact number.

Brittany
__________________
FORD SERVICE

p: 800.392.FORD
t: @FordService @FordTrucks @Ford
f: facebook.com/FordTrucks facebook.com/Ford
FordService is offline   Reply With Quote
Old 12-30-2014, 10:20 PM   #7
Junior Member
 
Join Date: Feb 2013
Posts: 16
Mentioned: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default that didn't go well P2112

That didn't go well.

The new computer came in at about 2.15pm MST this afternoon.

They installed a new computer & reflashed/ re-programmed today.
The mechanic test-drove, service manager test-drove, I test drove.
About 100 miles between the 3 of us.
I bought a very late lunch at about 3.30pm & re-hooked my trailer.

Truck stalled out immediately as I turned out of their lot.
3 more "wrench", and check engine lights as I circled back.

We connected the computer and found the fault only showed up "under load"
They finally agreed that the replacement throttle body with about 10k miles has failed/ out of spec.
It was only 1% out of spec when empty and would rarely trigger a "wrench" or CEL code.
Under load with a small trailer (bumper airstream trailer - 16ft 3500# trailer) - wrench/ CEL is almost immediate.
Throttle body fails by 15-20% out of spec.
Example-
Desired input is 46 degree angle
Response is about 25-30 degree angle hence 16-21 degrees off the desired angle.
(if you're unfamiliar- think about angle of tilt for air intake. 0 degrees is closed, 90 degrees is full open, wide open throttle WOT)

They are stripping a part of a new truck tomorrow because of the New Year and they want to get me fixed and out of their shop.
(I want to get out of Nebraska - nothing against this place - just not where I'm supposed to be right now)

I'm meeting them at 7.45am.
We'll test-drive with the laptop hooked up and trailer hooked.
1 more "wrench" / CEL as I went back to the hotel for the 4th night.

Please, please, please be the right fix.
92497pmu is offline   Reply With Quote
Old 12-30-2014, 11:10 PM   #8
Senior Member
 
Join Date: Jul 2011
Location: midwest
Posts: 1,711
Mentioned: 0 Post(s)
Thanked 188 Times in 145 Posts
Feedback Score: 0 reviews
Default

Dealer sounds pretty good! Hope it works for you
__________________
2001 f150 screw 4wd 5.4. Xlt -sold
2004 f150 screw 4wd 5.4. Xlt -sold
2011 f150 screw 4wd ecoboost lariat -sold
2013 f150 screw 4wd ecoboost 157" lariat - current
zx12-iowa is offline   Reply With Quote
Old 12-31-2014, 07:14 PM   #9
Senior Member
 
vozaday's Avatar
 
Join Date: Apr 2010
Location: Alberta
Posts: 976
Mentioned: 3 Post(s)
Thanked 110 Times in 98 Posts
Feedback Score: 0 reviews
Default

Any updates? Seems like a pain but at least the dealership seems more than willing to help you.
__________________
2013 F150 FX4 Appearance Loaded Eco w/Max Tow. Level lift with 305/55r20 Open Country ATII Extremes. 5 Star Tuned/X4. RX Catch Can/UPR CSS. 30" Hanning LED Bar. Rigid Backup Lights. JW Speaker Fogs. GlowShift Boost Gauge. Boost Bars. Remote Access.

1971 Mustang Grande 351C
vozaday is online now   Reply With Quote
Old 01-01-2015, 11:45 AM   #10
minitrucker
 
Join Date: Sep 2011
Location: IA
Posts: 278
Mentioned: 2 Post(s)
Thanked 18 Times in 16 Posts
Feedback Score: 0 reviews
Default

Damn I wish you would have stopped in Omaha as you passed through. I have a dealer that will bend over backwards for you. Omaha is 30 minutes from Lincoln.
1lowranger is offline   Reply With Quote
Old 01-01-2015, 11:45 AM
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Join F150 Forum

 

The Mustang Source

All times are GMT -4. The time now is 06:35 PM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.