2011 F150 5.0 No Eletrical Power!?!? - Ford F150 Forum - Community of Ford Truck Fans

Go Back   Ford F150 Forum - Community of Ford Truck Fans > Late Model F150s > 2009 - 2014 Ford F150 > 2011+ Engine Related Questions
Log In 


2011 F150 5.0 No Eletrical Power!?!?

Reply
 
 
 
Thread Tools Search this Thread
Old 12-19-2015, 05:23 PM   #1
Junior Member
 
Join Date: Dec 2013
Location: Anchorage AK
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default 2011 F150 5.0 No Eletrical Power!?!?

Drove my truck to work this morning and everything was fine. Went to go to lunch and truck has absolutely no electrical power?? Battery is fine, we tried jumping it. I turn the key on and get absolutely nothing, no dash, no lights, nothing. I have power to the main fuse panel and have checked all the fuses and relays. Stumped here, looking through forums for ideas. Any help would be greatly appreciated!
GottaFord11 is offline   Reply With Quote
Join F150 Forum

Join F150Forum.com Today - It's Totally Free!

Are you a Ford F150 fan? If so we invite you to join our community and see what it has to offer. Our site is specifically designed for you and it's a great place for Ford F150 Fans to meet online.
Once you join you'll be able to post messages, upload pictures of your truck, and have a great time with other Ford F150 fans. Whether your an old timer or just bought your F150 you'll find that F150Forum.com is a great community to join. Best of all it's totally free!

Join F150Forum.com Today! - Click Here JOIN FOR FREE


-->
Old 12-19-2015, 10:28 PM   #2
for fastening fabric
 
safetypin's Avatar
 
Join Date: Aug 2011
Location: san joaquin valley
Posts: 934
Thanked 146 Times in 112 Posts
Feedback Score: 0 reviews
Default

relay?
__________________
Garage:
2011 F-150 FX4 5.0 w/ locker
2013 F-150 XLT 5.0 w/ locker
2016 Focus w/ 2.0
safetypin is offline   Reply With Quote
Old 12-20-2015, 11:15 PM   #3
Junior Member
 
Join Date: Dec 2013
Location: Anchorage AK
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Checked all the relay's. A friend suggest one last thing before i was gonna get it towed. I disconnected the battery cables and held them together to discharge the capacitors in the ECM. Hooked the battery back up and sure enough everything worked. I might have something going bad in the body control module i guess or maybe this was just a fluke incident. Time will tell, hopefully it doesn't happen again.
GottaFord11 is offline   Reply With Quote
Old 12-29-2015, 12:19 AM   #4
Junior Member
 
Join Date: Dec 2015
Location: Central Illinois
Posts: 7
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Default

Hope they fixed that little problem for my 2012.
5.0-V10guy is offline   Reply With Quote
 
 
Reply

Similar Threads
Thread Thread Starter Forum Replies Last Post
Truck fell off jack MusicBro 1987 - 1996 F150 13 11-28-2015 01:24 PM
Turn Signals cancelling Cruise Control sammyg 2004 - 2008 Ford F150 12 11-28-2015 10:18 AM
Power Mirrors / Tow Mirrors 2015 F-150 mgreen909@gmail.com Aftermarket Products, Reviews & Installation 2 11-27-2015 09:50 AM
Texas: Truck tires Hankook Dyanpro HT 265 60/R18 RickJrMendez General F150 Items 0 11-25-2015 06:47 AM
Lighting up my Rear End diegoo.jayjay 2009 - 2014 Ford F150 12 11-22-2015 03:39 PM


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


All times are GMT -4. The time now is 08:43 AM.


Copyright 2006 - 20011 F150forum.com
This site is in no way affiliated with the Ford Motor Company.